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Practical example  
Three dimensional bar structure project with steel, 

aluminium and timber sections, including foundations 

(pad footings, pile caps, strap and tie beams) and 

bracing systems against lateral loads, allowing ties that 

work only in tension. Joint and baseplate design for 

metallic structures. 
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1 Introduction 
For this example, a 40m long by 20m wide warehouse will be designed. It will consist of 9 

frames at 5m intervals. Their ridge heights will be at 10m and lateral heights at 8m. Within 

the warehouse, a small slab will be built at a height of 4m corresponding to the location of 

the office. The warehouse will have two openings measuring 6x5m on its right side and one 

with the same dimensions on its left side. 

The first step to carry out is to establish the loadcases corresponding to the loads acting on 

the structure. 

 Dead loads: 

o Self weight of the purlins 

o Roofing material (80mm sandwich panel and 0.24kN/m2). 

o Self weight of the joist floor slab (25+5): 3.7kN/m2 

o Screed: 1.2 kN/m2. 

 Live loads: 

In accordance with table 6.2 of Eurocode 1: Actions on Structures – Part 1-1: General 

actions – Densities, self weight, imposed loads for buildings, the live load 

corresponding to a B use category (office zones) is of 2 kN/m2. 

 In accordance with table 6.10 of Eurocode 1: Actions on Structures – Part 1-1: General 

actions – Densities, self weight, imposed loads for buildings, the imposed  load 

corresponding to a category H roof (only accessible for normal maintenance and 

repair) is of 0.4 kN/m2. 

 Wind action: 

In accordance with Eurocode 1. Reference speed 26m/s, Terrain category: Single III 

Zone with vegetation or buildings distributed in a regular manner, Land orography Flat. 

 Snow loading: 

In accordance with EC1. 
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2 Portal frame generator 
The Portal frame generator will be used to design the purlins of the roof and to generate 

the appropriate loads to then be used in CYPE 3D.  

Open the Portal frame generator. From the File manager, select New. Give the job a name 

(e.g. wh_1) and introduce a description (e.g. warehouse example). 

 

Figure 1 

Having accepted, a new window appears asking whether you wish to introduce a new 

frame. Choose answer yes and in the new dialogue box select dual pitch. A new window 

will open where the type of roof can be selected. Leave the default option: Rigid frame. 

Introduce the dimensions shown in the figure, by pressing on the dimensions to edit them. 

 

Figure 2 
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Having accepted the dialogue box, the previously described frame will appear on the main 

screen. If any modifications are to be undertaken, click in the middle of the frame and a 

window will open containing various edit options. 

 

Figure 3 

Select General data > Job general data and fill in the data as shown in Figure 4 (number 

of spans, which in this case is 8, the distance between the frames: 5m, the weight of the 

roof covering and its live load, the codes to be used to generate the wind and snow loads). 

It is essential the With lateral covering option be activated so the lateral and front wind is 

generated correctly. In this case, the lateral covering will consist of precast concrete panels 

and will rest on the tie beams of the foundation and so, its self weight can be ignored by 

assigning a value of zero to its weight. 
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Figure 4 

For the wind load, select Eurocode 1, reference speed 26m/s, terrain category Single and III, 

flat land in the X and Y directions and a service period of 50 years. 

 

Figure 5 
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Mark the With openings box, which will open the Façade openings dialogue box, where the 

dimensions of the openings and the position of their centre of gravity with respect to the 

origin. 

 

Figure 6 

The following image displays the location of these openings. 

 

Figure 7 

It must also be indicated, within the Façade openings box, whether the façade openings are 

permanently open or not. If the openings can be closed, the program generates two new 

loadcases for each wind load; one combining the external pressure with the maximum 

internal pressure, if the leeward openings are closed, and the other with maximum suction 

if the windward openings remain closed. For this example, select that the openings are 

permanently open. 

For the snow loads, select Eurocode 1, United Kingdom, Republic of Ireland, Zone 2, 

Normal landscape and a topographic height of 0m. 
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Figure 8 

For the load combinations, select use category B: Office use. (In the image, it can be seen 

that this is in accordance with that stated in the Eurocode. It may occur that if the user has 

not used the required code in a previous job, that the option to select it may not appear. If 

this is the case, select any option, then once the frame has been completely defined, the 

appropriate code can be selected in Configuration > Codes. Having selected the code, click 

on Job data > General job data and modify the information). Accept the dialogue box to 

confirm the data. 

For this example, the lateral covering will consist of lightweight concrete panels, therefore 

it must be specified that there is lateral cover otherwise the wind loads acting on the sides 

of the frame will not be generated. To do so, click outside the frame, at the side at which 

the wall is to be introduced. Click on Lateral wall and indicate it is to have a height of 8m. 

Activate the Braces the column against buckling box but do not activate the Self-

balanced box, by doing so, the wind pressure loads that are generated are transmitted to 

the columns of the warehouse. 

 

Figure 9 
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Repeat the process with the wall on the other side. The walls are displayed on screen. 

Now the roof purlins are to be defined. To do so, select General data > Edit lateral and 

roof purlins > Purlins on roof. Here the deflection limit is to be specified as well as the 

number of spans the purlin is to cover and how it is attached. For the section type, press 

the button containing the section name, and select Rolled from the scroll menu and the 

IPE section series. Click on Accept. 

 

Figure 10 

Once the section type has been selected, there are a further three options for its 

optimisation. 

 

Figure 11 

The first option optimises the section for the selected separation. In this case the program 

will run through the sections of the series verifying them for the selected separation. 
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The second type optimises the separation between the purlins for the selected section. 

Finally, the option is available to design the separation and section, where the minimum 

and maximum separation to check is to be indicated as well as the separation increment 

for each iteration. Once the design has concluded, the results will be displayed as a list 

where the section is shown as well as its weight and separation. Those that fail have a 

forbidden or hazard sign next to them. To select a section from the list, double click on its 

row. It will be highlighted in blue and, upon accepting the dialogue box, shall be 

incorporated in the job.  

When choosing the layout, users must check that the selected separation is valid for the 

type of sandwich panel that is going to be used in the project; in this example, change the 

separation value to 1.40m and click on the first design option. From the results, select an 

IPE 120. 

 

Figure 12 

Now the purlins have been selected, the data can be exported to CYPE 3D. To do so, click 

on General data > Export to CYPE 3D. Select the options shown below. The number of 

frames and type of support conditions to be generated must be indicated and if the 

buckling coefficients to be generated are those for sway or non-sway framed (as ties will be 

introduced later on in CYPE 3D, select the buckling coefficients to be generated for non-

sway frames). 

In case the selected code has different load areas for the roof when considering wind 

loads, the planes of the frames are not to be grouped as the loads are not symmetrical and 

errors could arise if frames with different loads are grouped. 
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Figure 13 

 

2.1 Loads generated by the program 

The program generates the loadcases corresponding to permanent loads, live loads on the 

roof, wind and snow loads. 

2.1.1 Dead loads 

The program generates the dead loads due to the self weight of the purlins and the roof 

covering. 

The dead load due to the floor slab has to be defined in CYPE 3D and add this load to the 

dead load loadcase. 

2.1.2 Live loads 

Given that a load of 0.4 kN/m2, corresponding to a category H roof (only accessible for 

normal maintenance and repair) has already been chosen, the program will generate the 

loadcase and load. 

2.1.3 Wind loadcase 

The warehouse is exposed to wind acting in all four directions: 0º, 90º, 180º and 270º. 
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Figure 14 

 

This implies that there will be at least four wind loadcases. The roof in this example has a 

pitch of +11.31º. In accordance with table 7.4a of Eurocode 1, Part 1-4, two loads are 

generated for this pitch, which implies the loadcases for wind at 0º and 180º are duplicated 

due to these situations. 

The warehouse contains openings, but as they have been defined as being permanently 

open, the loadcases are not duplicated for the sides at which the openings are located. 

 

2.1.4 Snow loadcase 

The program determines the snow load using the height and winter climate zone. 

Due to snow drifting, unsymmetrical distributions of the snow may arise, where one side of 

the roof is loaded and the other with half the load. For this reason, three snow loadcases 

are created when exported to CYPE 3D. 
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3 CYPE 3D 

3.1 Node and bar introduction 

Upon accepting the dialogue box, a wizard is launched to guide users with the introduction 

of the job in CYPE 3D. All these options can be modified later on in the Job menu. 

 

Figure 15 

 

Figure 16 
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Figure 17 

 

 

Figure 18 

After the wizard has finished, the program will ask for a name to be entered for the 

structure in CYPE 3D. Once this dialogue box has been accepted, the generated structure 

will appear with its loads in CYPE 3D. 
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Figure 19 

3.1.1 Layer management 

As of the 2015 version, a layer system is available to manage the views of the bars and load 

panels. This is a tool to help program users as all the bars which hinder the introduction of 

new elements in the program can be deactivated, as well as allowing for an identification 

colour to be assigned to each layer, and so display all the elements assigned to that layer in 

that colour, if the option is activated. 

Now the layers to be used in the job will be defined. This can be done via Job > Layer 

management or by pressing keys “Alt + q”. A window will open in which layers can be 

added, specify which is the active layer and configure its visibility. Add the following layers: 

Columns, Beams, Ties, Floor slab_beams, Floor slab_columns. 

 

Figure 20 
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3.1.2 Show/hide planes 

The reference lines generated by the program may be eliminated to work more easily. 

First of all, go to Planes > Show/hide planes and upon accepting the dialogue box, select 

all the nodes whose reference lines are to be hidden, then press the right mouse button to 

validate the selection. If later on, these are to be reactivated, it can be done using the same 

method but using the Show option. 

The second step is to deactivate the Show/hide new planes option also in the Planes 

menu. This way, when new nodes are introduced in the job, their associated planes will not 

be displayed. 

 

Figure 21 

3.1.3 Bar introduction and dimensioning 

The bars supporting the internal slab of the warehouse will now be introduced, as will the 

columns of the gable wall: 

1. Activate the planes where the support nodes are located; in this case the bottom left-

hand support and the ridge node of the gable wall. 

 

 

Figure 22 
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2. Using the option Node > New, introduce the three nodes by snapping to the reference 

line of the bottom left-hand node. Please recall that to carry out this operation, the 

Nearest and Intersection object snaps must be activated in the Object references 

option in the top part of the menu
 . 

 

Figure 23 

Introduce the first point between the left support and ridge reference lines; the second by 

snapping to the intersection of the ridge and support reference lines and the third between 

the ridge and right support reference lines. 

 

Figure 24 
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To place these nodes at their exact positions, click on Planes > Dimensions > Add. 

Introduce the value of the distance, in this case 5m, and click on the support reference line 

and the first new node. Then, click again on the new node followed by the next node. 

 

Figure 25 

 

Figure 26 

 

Figure 27 
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Figure 28 

Another way of introducing the nodes is by selecting the configuration icon from the top 

toolbar
 

. This way the program will always ask for the dimension to be 

introduced when a new bar or node within a bar is defined. 

 

Figure 29 
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Having positioned the nodes, the new bars representing the end columns can be 

introduced. To do so, a 2D view will be created of the plane containing the gable wall. 

 

Creation of new views 

To create windows with new views of the structure, go to Window > Open new > 2D view 

in a plane orthogonal to the X, Y or Z axis. Mark two planes defining the 2D plane. A 

dialogue box will appear asking for a name for the new window (e.g. Gable wall). 

 

Figure 30 

 

The new view will automatically appear on screen. By clicking on Window > Tile vertical, 

the 3D view and 2D view can be seen at the same time and if the cursor is moved in the 2D 

window, the plane in question is shown in the 3D window. 

 

Figure 31 
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Warning: if the window is closed, the view will be lost and will therefore have to be 

redefined. Use the maximise and minimise buttons of the window to change between 

views. 

Using the 2D view, the bars from the nodes that have been previously defined will be 

introduced up to the lintel. First of all though, the active layer must be changed to 

Columns. Press the Layer management icon , select “Columns” as the active layer and 

accept. Click on Bar > New. A window will appear displaying the active layer to which the 

bars to be introduced will belong to, the type of section that will be introduced and its 

layout. A list is also available which displays the section types that have been introduced in 

the current job, allowing for a quick selection process. 

 

Figure 32 

As the Eurocodes were selected as the design standards, the program automatically opens 

with a predefined series. Users can change this section series by pressing on the section 

button. Having done so, the Describe section window will open in which, having selected 

the material, the type of section to be introduced can be chosen. By fist of all choosing the 

material and then pressing the Edit the list of elements button , users can define a 

section, by defining its geometry, or import a section series from a library, by pressing the 

Import of predefined section series button . By clicking on this button, a window will 

appear containing all the manufacturer libraries which contain the previously selected 

section. In our case, as the section series has already been selected, close the Import of 

predefined sections window and the Series of sections window, to arrive at the Describe 

section window.  

In the Describe section window, select IPE 240 and begin to introduce the bars.  

To do so, bring the cursor close to the node until it changes to a cyan colour. Click on it with 

the left mouse button and bring the cursor close to the intersection of the bar with the 

lintel until the object snap symbol appears. Click with the left mouse button to confirm the 

point. Click on the right mouse button to complete the introduction of the first bar and to 

be able to select the second origin node, otherwise bars will continue to be introduced 

from the last marked node. 
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Figure 33 

 

Repeat the process with the remaining bars of the gable wall and then repeat for the 

opposite gable wall. 

 

Figure 34 
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Now change the layer by pressing the Layer management button  or by pressing Alt+q. 

Select “Floor slab_beams” as the active layer; this will be used to introduce the beam which 

will support the floor slab. Return to the 2D gable wall view by pressing Window > 2D: 

Gable wall. Click on Bar > Generate node at intersection points or the  icon from the 

toolbar, (it is important this option is activated when a bar intersecting another is 

introduced so that nodes are generated at their intersection points, otherwise the program 

will interpret that the bar that has been introduced does not touch the intermediate 

columns). Now click on Bar > New and place the cursor on the left column of the frame, 

click with the left mouse button and introduce a distance of 4m from the bottom support. 

 

Figure 35 

Bars 

When introducing bars, it is important to only introduce them as they are really going to be 

used on site. In other words, if the slab beam is going to be a single 20m element 

supported by the intermediate columns, the bar is to be introduced from one end column 

to the other end column. This way, the program interprets that the whole bar is a single 

element and so when the bar is described, the fixity coefficients will be applied to the 

element. If, on the contrary, 4x5m bars are going to be used on site, 4 bars should be 

introduced from column to column. 

If a bar has been introduced by accident, and the real intention was to introduce 

independent bars, the error may be amended using the Bar > Create elements option, 

then clicking on the initial and final nodes of the bars to be created. With this option, a bar 

can be divided into several smaller bars or combine several small bars to create a large 
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bar. The program represents the bars with a thick line when an intermediate node is 

present between the two end nodes of a bar. 

Return to the 3D view by selecting it from the Window menu. Now create a new view for the 

second frame to finish off defining the floor slab area. 

Introduce the beam spanning from the column on the left to the column on the right at a 

height of 4m. 

 

Figure 36 

Now introduce the 3 columns reaching the beam that has been introduced, having first 

changed the active layer to Floor slab_columns and select an IPE-220 section. 

 

Figure 37 
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Return to the 3D view and select “Beams” as the active layer. Introduce the transverse bars 

of the floor slab reaching the gable wall. For these, use an IPE-160 section. 

 

Figure 38 

Carry out the same process to tie the roof of the two gable walls to their closest frame. 

 

Figure 39 
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Bracing 

Now to define the bracing at the end frames. To do so, select “Ties” as the active layer and 

choose a solid round ø R16 bar. Remember to deactivate the option to Generate nodes at 

intersection points  in the Bar menu, since the bars to be created must be 

independent from on e another. 

This option is valid as long as the selected bars meet the following conditions: 

 Diagonal bars described as ties consist of bracing and are contained within a 

quadrilateral frame, or along three sides for bracing reaching external supports. 

 The program only considers these bars to work in tension, hence neither buckling nor 

fixity coefficients may be assigned to them. 

 No loads may be applied on them 

 

Figure 40 

Finally, select the “Beams” layer and introduce the beams which define the openings in the 

lateral frames, at a distance of 6m from the ground, and the beam tying the top of all the 

columns. Define these beams as IPE-160 sections. 
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Figure 41 

3.2 Node and bar description 

Once the bars and nodes have been introduced, the supports (external fixities) of the new 

columns can be described. The other supports have already been described when the 

frame was defined in the Portal frame generator. To do so, go to option Node > External 

fixity. Select those nodes which have yet to be described individually (or use a capture 

window). Having selected the nodes, click on the right mouse button and the External fixity 

dialogue box will open where the type of support can be defined. Select the Fixity option 

and leave all options as fixed. 

 

Figure 42 
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The next step consists in describing the type of section to be assigned to the bars that were 

exported from the Portal frame generator, as well as their material and associated layer. To 

do so use the Bar > Describe section option. First select the columns of the frames and 

having done so, click on the right mouse button to indicate the type of section. 

 

Figure 43 

Select the rolled steel section option from the images at the top of the dialogue box and 

from the scroll menu select an IPE-300 section. 

 

Figure 44 
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Figure 45 

Using the Assign elements to layer option in the Job menu, select the columns that were 

exported by the Portal frame generator and assign them to the columns layer. Similarly, 

select the lintels and assign then to beams layer. 

 

3.3 Section layout 

The next step consists in describing the layout of the bars, i.e. the angle and level they will 

have on site. Start with the intermediate columns of the gable wall.  

Activate the option Bar > Describe disposition, select the columns of the gable wall and 

right click. In the emerging window, select the 90o rotation button. 
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Figure 46 

3.4 Grouping of equal bars 

The wind loads, due to the openings of the warehouse not being symmetrical, result in 

non-symmetrical pressures and therefore the design of the bars after the analysis cannot 

be symmetrical. To avoid this, the bars may be grouped using the Group option in the Bar 

menu. 

Select all the IPE-300 columns of the frames then right click with the mouse to validate the 

group. 

 

Figure 47 
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This way, the columns are grouped and when a modification is carried out on a column of 

the group, all the columns are modified at once. 

Repeat the same process with the IPE-300s for the beams of the frames. Group the IPE-240 

columns of the gable wall, the IPE-240 beams and IPE-220 columns of the office slab and 

the IPE-160 bracing beams between frames. Finally also group the ties. 

 

3.5 Materials  

Once the bars have been described, the material they are made of can be indicated using 

the option Bar > Describe material. 

Select a bar, and the program proposes the material defined in General data be used 

(which can be accessed by clicking on Job > Steel sections). Alternatively, a material can be 

defined for the bar. 

 

Figure 48 

For this example, leave the Material selected in the general data options (S275) option 

for all the bars. Double check by clicking on Job > Steel sections that the selected material is 

S275 for rolled steel. 

3.6 Fixity coefficients 

The next step consists in pinning the ends of the bracing bars between frames. This is done 

using the option Bar > Pin ends. By clinking at the centre of each bar, both ends will be 

pinned. If only one of the ends is to be pinned, just click on the end in question. Floor slab 

beams reaching the webs of the columns are also to be pinned. The beams at the ends of 

the gable wall containing the floor slab will be fixed to the external columns and pinned to 

the internal columns, i.e., each end connecting to the internal column of the floor slab must 

be clicked on. Also pin the top end of the centre columns of the gable walls. 
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3.7 Loads 

Having described the geometry, the loadcases which are yet to be added to those provided 

by the Portal frame generator can be completed. 

 

3.7.1 Add loadcase 

To add or modify loadcases, use the option Job > Loads. The Portal frame generator has 

generated 1 dead load loadcase, 6 wind loadcases and 3 snow loadcases.  

As this example includes a slab for office use, a new live load loadcase must be created. To 

do so, click on the option and in the emerging window click on Additional loadcases. Since 

the floor slab that has been added is for office use, a new live load loadcase must be 

defined but in use category B (Offices). 

 

Figure 49 

Once category B has been defined, click on the edit button corresponding to the live load 

and add the new loadcase. 

 

Figure 50 
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Figure 51 

 

Figure 52 

 

Figure 53 
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3.7.2 Panel loads: panels and surface loads 

Having created the live load loadcase, the corresponding loads can be introduced using the 

option Load > Introduce panels.  

Once the option has been selected, the load panels that have been created by the Portal 

frame generator will be displayed. To introduce a load panel, select the points that form 

the polygon of the slab (Fig. 54). Having done so, click on the right mouse button and select 

the direction the applied loads are to span. For this example, select the direction parallel to 

the longer side of the warehouse. 

 

Figure 54 

Upon selecting the direction of the applied loads, by clicking on the right mouse button, a 

new window will appear where the loads associated to the panel can be introduced. Add 

the following loads associating each one with its corresponding loadcase. First, add a load 

associated to the dead loadcase corresponding to the dead load of the slab whose value is 

3.7 kN/m2; another load of 1.2 kN/m2 corresponding to the screed and finally a live load of 

2 kN/m2. 
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Figure 55 

Accept the Loads on panel window and the load distribution carried out by the program 

can be consulted. To do so, click on Load > Visible loadcase, select loadcase LL Office, 

accept and the loads generated on the bars for that loadcase will be displayed 

automatically. 

 

Figure 56 
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The lintels of the openings will have to support the loads from the small part of the façade 

they have to support. Go to Load > Introduce loads on bars and introduce a uniform load 

of 7.5 kN/m in the self-weight loadcase, on the three lintels. 

 

3.7.3 Wind loads 

The surface loads that have been generated by the program for each wind loadcase can 

also be consulted. To do so click on Load > Viewed loadcase. For this example, activate 

the loadcase corresponding to 0º, external pressure type 1 (W(0º) H1 from the scroll menu) 

and the loads generated on the bars will automatically become visible. If, additionally, the 

surface loads applied by the Portal frame generator are to be consulted, click on Load > 

Edit surface loads (Fig. 57). The program generates the surface loads corresponding to the 

external pressure for each panel that has been introduced and the loads corresponding to 

the internal pressure, as separate loads. 

 

Figure 57 

3.8 Buckling 

Now that the loads acting on the warehouse have been completed, the buckling 

coefficients of the bars that have been introduced in the program can be defined. The 

buckling coefficients of the main frames in their plane have to be modified because the 
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Portal frame generator has provided buckling coefficients for non-sway frames, as was 

explained in Fig.14, which is correct in the longitudinal sense of the warehouse due to the 

bracing, but is not the case (until proven) in the other direction. 

To assign the buckling coefficients, select Bar > Buckling and select the IPE-160 beams 

bracing the frames. Bearing in mind the structure has IPE-100 purlins with a separation of 

1400 mm and are rigidly fixed to the cover panel and additionally, the warehouse is to have 

150 mm concrete panels as its external wall, it can be assumed that these bars will not 

buckle; the whole structure would have to be completely loaded for this phenomenon to 

occur. Therefore, a buckling coefficient,  with a value of zero in the XY plane and a value of 

1 in the other plane will be assigned to these beams. 

 

Figure 58 

As for the IPE-160 beams joining the two frames supporting the office slab, the same rules 

can be applied to them as in the previous case, due to the presence of the slab preventing 

the steel sections from buckling in their XY plane. 

For the IPE-220 columns supporting the internal frame of the slab, a buckling coefficient of 

=0.7 is to be used. This way their base will be fixed and their top pinned in both planes. 

Finally, the IPE-240 columns of the gable wall will not be able to buckle in the XY plane due 

to the presence of the wall in which they are contained. A value of =0.7 (fixed at its based 

but pinned at the top) will be applied to the XZ plane. It is important to remember that 

when there are intermediate nodes present, such as at the gable wall containing the floor 
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slab, the value has to be modified. A value of =0.7 has to be assigned to the three columns 

for each of their complete lengths, hence an equivalent buckling length has to be assigned 

to each part of the columns (Fig. 59): 10 x 0.7 = 7m for the centre column and 9 x 0.7 = 

6.3m for the other two columns. 

 

Figure 59 

For the lintels of the three openings, assign buckling coefficient, = 1 (pinned) in both 

planes. 

As was mentioned previously, the non-sway condition is correct for the longitudinal 

direction of the warehouse but not for the transverse direction until it is proven otherwise. 

Therefore, the buckling coefficients for the central frames in that direction have to be 

modified. 

If the warehouse is exported again from the Portal frame generator, however this time 

stating the frames are sway frames, the buckling coefficients applied by the program in the 

planes of the frames are = 1.20 for the columns and = 1.135 for the beams. These values 

are to be assigned to the central frames of our example. For bars with intermediate nodes, 

the required modifications have to be carried out, or alternatively, assign the following 

buckling lengths in the XZ plane to all the central frames: 

• For the columns lk = 1.20 x 8 = 9.6m 

• For the beams lk = 1.135 x 10.198 = 11.575m 
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3.9 Lateral buckling 

Lateral buckling can occur in the beams of the central frames of the warehouse due to 

wind suction on the roof. If so, this would affect the bottom flange of the sections. This 

situation is avoided in practice by bracing the bottom flange against this phenomenon. To 

simulate this in the program, use the option Bar >Lateral buckling and select the IPE-300 

beams of the roof of the warehouse. Once selected, right click with the mouse button to 

edit the lateral buckling values. For the bottom flange of these beams, place braces every 4 

purlins with a free buckling length of Lb=4.2m. 

 

Figure 60 

For the IPE-300 columns of the central frames indicate the lateral buckling is braced in both 

planes. 

For the lintels of the three openings, assign a lateral buckling coefficient of v= 1 (pinned) to 

the top flange, as it is the flange that is in compression. 

 

3.10 Analysis and design of the structure 

Once all the previous steps have been carried out, the structure can be analysed and then 

designed. To analyse the structure click on Analysis > Analyse. A window will appear 

offering various analysis options: Do not dimension sections, Quick section design or 

Optimum section design. In this case select the first option: Do not dimension sections. 

Displayed in the bottom part of the window are a further two options: Check bars and 

Consider the finite dimension of the node. Select Check bars and, since the joints will be 

designed later on, also mark the Consider the finite dimension of the nodes box. 
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Figure 61 

 

3.10.1 Check bars 

Once the analysis procedure has concluded, click on Analysis > Check bars to validate the 

initial design, or if, on the contrary, bars have to be modified and the structure must be re-

analysed. 

Upon selecting this option, any bars not verifying all the checks will be displayed in red. By 

moving the cursor over one of the IPE-300 sections of one of the central frames, a box 

appears informing users of the error. If this bar is then clicked on, a new window emerges 

indicating which sections of the series verify all the checks and highlighted in blue is the 

section currently in use in the job. To modify the section, simply double click on the row 

containing the replacement section and accept (this row will then be highlighted in blue). In 

this case, do not modify the initial section, as the failure percentage is not too great and it 

is best to check the tensile state of the bar to be able to choose between changing to a 

greater section or provide a haunch at its connection with the column. 
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Figure 62 

3.10.2 Force consultation 

Activate the option Analysis > Forces. In the emerging window mark Envelope, Selected 

bars only and Stress/Use. Click on the beam that was previously selected using the Check 

bars option and the force diagram of the tensile state of the bar will be drawn in the XZ 

plane. The part of the bar verifying the tensile force of the bar is displayed in green and 

that not verifying the tensile force of the bar is displayed in red. 

 

Figure 63 
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It can be seen that the area in which the beam connects to the column fails. The amount by 

which it fails can also be seen by activating the Display maximum and minimum values 

option at the bottom of the Forces dialogue box. 

 

Figure 64 

The U.L.S. checks report can be seen for any bar of the structure, and that way see due to 

which forces and force combinations a bar may fail. To do so, select Analysis > U.L.S. 

checks, mark At the worst point and click on the beam. A report will appear displaying all 

the checks that have been carried out on the bar. 

 

Figure 65 
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The next step consists in optimising the sections. How to proceed in this situation depends 

on the practical solutions each designer is used to applying. For this example, carry out the 

following changes: 

 The columns, except those of the gable walls, those supporting the floor slab, and the 

two corner columns at the end where there is no floor slab, are to be increased to IPE-

360 sections. 

 The two corner columns mentioned above are to be increased to IPE-500 sections. 

 The beams of the central frames are to be increased to IPE-360 sections with 1.5 m 

bottom haunches. 

 Ties are changed to 20 mm solid bars. 

 The central columns of the gable walls are to be increased to IPE-270 sections. 

 The lintels of the openings are also increased to IPE-240 sections. 

3.11 Joints 

As of the 2008 version of CYPE 3D, the program incorporates the analysis and design of 

connections in accordance with several design codes. 

More information on the types of connections that are designed can be found on the 

following web pages: 

https://info.cype.com/en/product/welded-joints-of-rolled-and-welded-steel-i-sections/ 

https://info.cype.com/en/product/bolted-joints-of-rolled-and-welded-steel-i-sections/ 

https://info.cype.com/en/product/welded-connections-of-rolled-and-welded-steel-i-

sections-for-building-frames/ 

https://info.cype.com/en/product/bolted-connections-of-rolled-and-welded-steel-i-sections-

for-building-frames/ 

https://info.cype.com/en/product/joints-v-flat-trusses-with-hollow-structural-sections/ 

 

3.11.1 Generate joints automatically 

The program allows users to define each joint individually, but also has the option to 

Generate the joints. This implies the program analyses the joints that can be applied to 

each node of the project by taking into account the bars reaching each node. 

https://info.cype.com/en/product/welded-joints-of-rolled-and-welded-steel-i-sections/
https://info.cype.com/en/product/bolted-joints-of-rolled-and-welded-steel-i-sections/
https://info.cype.com/en/product/welded-connections-of-rolled-and-welded-steel-i-sections-for-building-frames/
https://info.cype.com/en/product/welded-connections-of-rolled-and-welded-steel-i-sections-for-building-frames/
https://info.cype.com/en/product/bolted-connections-of-rolled-and-welded-steel-i-sections-for-building-frames/
https://info.cype.com/en/product/bolted-connections-of-rolled-and-welded-steel-i-sections-for-building-frames/
https://info.cype.com/en/product/joints-v-flat-trusses-with-hollow-structural-sections/
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Figure 66 

Once the joints have been generated, all the nodes for which a joint has been detected are 

displayed in blue. If no further modifications are to be carried out, use the Design option to 

design all the joints that were generated in the previous step. 

 

Figure 67 
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A window will appear where the type of connections to be used in the design must be 

chosen: welded, bolted or keep the previously defined connection method. This latter 

option is to be used if changes have already been made to the types proposed by the 

program. 

 

Figure 68 

Select bolted connections and after the design process, the joints that have been solved 

are displayed in green and those failing a check in red. 

 

Figure 69 

Use the Edit option to edit the joints and see why they fail. In this case, edit one of the 

column-beam joints at either gable wall. A window will open displaying the selected joint. 
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To see where the problem lies, press the Design button  and select to design the joint 

with bolted connections.  

 

Figure 70 

Here we can see there is not enough room for the beams to be connected correctly to the 

columns if we are to use bolts. Click on the Design button and choose to desing the joint 

using welded connections. 

 

Figure 71 
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The joint is now designed correctly. 

 

Figure 72 

3.11.2 Define joints manually 

In the previous section, we saw how joints can be defined automatically. In this section, we 

shall see how joints can be defined manually by specifying one by one the joints to be 

analysed in the job. To do so, using the New option in the Joints menu, select the bars 

reaching the node which are to be connected, then click on the right mouse button to 

confirm the selection. A window will open displaying the connection to be edited. 

 

3.11.3 Editing the joint 

When a new joint or connection is created, a window opens displaying the joint in question. 

On the left of the window is a list of the components of the joint together with their 

individual edit buttons. To the right of the list is the graphical 3D view of all the 

modifications that have been carried out on the node. Any errors that have been 

encountered upon designing the node are displayed below the image. Lastly, along the top 

are the Design, Code check, Complete report of the node and Detailing buttons.  

So, click on Joints > New and select the column-beam joint of one of the central frames. To 

do so select the four bars that reach the node, then right click to confirm the selection. A 

window will open displaying the joint. 
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Figure 73 

Edit the column and use the End trim option indicating the trim is to be carried out in 

accordance with the IPE 360 beam. The column is then trimmed along a plane parallel to 

the flange of the beam. 

 

Figure 74 

Now the stiffeners of the column have to be created. To do so, use the Generate 

reinforcement elements option and the stiffeners of the column are generated 

automatically. Since the column has been trimmed, one of the stiffeners has to be adjusted 

to the new geometry of the column. 
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Figure 75 

The program contains the following options to modify the joint. These can be seen along 

the top of the window: 

 Reverse the viewpoint. Using this option, the elements located on the opposite side 

of the beam can be seen and modified. 

 Generate reinforcement elements. If there are no reinforcement elements, the 

program automatically generates them. 

 End trim. This option opens the window we saw previously, to indicate how the 

column ends.  

 Introduce stiffener. This can be done in two ways. The first consists in selecting the 

blue dot located at the intersection of the beam and the internal side of the column flange 

and moving the cursor to the opposite flange. The program will introduce the stiffener. The 

second method consists in selecting the yellow dot that is surrounded by a red circle 

located at the intersection of the beam flange and column flange. If the cursor is placed 

near the dot, the introduction possibilities will be displayed. If it is clicked on, the yellow dot 

on the opposite flange will then have to be selected to define the position of the other end 

of the stiffener. 

 Edit stiffeners. Allows for several stiffeners to be edited at once to modify their 

dimensions and welds. 

 Delete stiffeners. 

 Move stiffeners.  
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 Introduce new reinforcement element for moment connection at the web. 

Introduces a vertical reinforcement element between the horizontal stiffeners to aid in the 

connection of the beams with the web of the column. 

 Edit reinforcement element for moment connection at the web. By selecting the 

connection plate between the beam and stiffener, a new window opens in which the 

dimensions, position and welds of the connection plate and reinforcement can be edited. 

 

Figure 76 

 Delete reinforcement element for moment connection at the web. 

 Introduce reinforcement plate at the web. To introduce a reinforcement plate, the 

two stiffeners must be selected, between which the web of the column will be reinforced. 

 Edit the reinforcement plate at the web. If the plate is selected, users can modify its 

thickness, material and welds. 

 Delete the reinforcement plate at the web. 

To continue with the example, use the Delete stiffeners option  to delete the stiffener. 

Then click on the  option to reintroduce it and select the yellow point with the red circle. 
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Figure 77 

 

Figure 78 

Accept and the changes will be saved. Edit the type of connection of the IPE 360 beam. 
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Figure 79 

Now edit the IPE-160 beams. In this case, they are to have a pinned connection using 

lateral plates. 

 

 

Figure 80 

 



 

 

 

CYPE 3D – Practical example / 53 

Accept and click on the Code check icon to see if the joint has been designed correctly and 

if not, modify those points where it fails a check, then repeat the code check process. 

This joint design process must be repeated for the remaining nodes. If joints have already 

been generated, a joint can be assigned to other nodes if the program detects they are 

composed of the same number of sections. To do so, use the Assign option. Select the type 

of joint to be assigned, the Edit connection window will open, accept and all the nodes to 

which the joint can be assigned will be displayed in yellow. By clicking on the node, the type 

of joint will be assigned to it. 

 

Figure 81 

Joints generated by the program are grouped automatically. However, if a joint is 

supporting much greater forces than the rest of the joints, it may be best to Ungroup the 

joint so not to oversize the other joints of the group. 

The program has an option to Block joints which are not to be modified if the Design 

option is reused.  If a blocked joint is edited, a locked padlock is displayed in the top right-

hand corner of the edit window of the joint (Fig. 82). If you wish to unblock it, just click on 

the lock. 
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Figure 82 

3.12 Baseplates 

Now that the sections of the warehouse have been designed, the baseplates will be 

designed. As of the 2015 program version, baseplates can be edited within the Joints menu. 

When joints are generated, the baseplates are also generated and can be edited in the 

same way as was seen in the previous section with the Joints. 

 

Figure 83 
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3.13 Foundations 

3.13.1 Footing introduction 
Upon reaching this point, click on the Foundations tab at the bottom left hand corner of the 

screen to design the foundations. The new screen displays a floor plan layout of the 

sections whose nodes have been described as having external fixity. The baseplates are 

drawn if they have been defined previously. 

 

Figure 84 

To introduce the footings and tie beams, click on Foundation elements > New. 

 

Figure 85 

Click on Reinforced concrete footing in the floating menu and from the window that 

appears, select a Rectangular footing (third option from the left). 

 

Figure 86 
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Upon accepting this option, the cursor becomes a footing. Depending on the area of the 

column over which the cursor is moved, the footing will become a corner footing, centred 

footing or edge footing. By clicking on the starts with the left mouse button, introduce, as 

centred footings, all the footings of the warehouse. 

 

Figure 87 

3.13.2 Tie beam introduction 

Proceed introducing the tie beams. To do so use the Automatic beam option, and by 

clicking from one start to another, the beams are introduced. 

 

Figure 88 
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3.13.3 Data definition before the design 

Having defined the geometry of the foundations of the warehouse, the allowable bearing 

pressure of the soil and the type of concrete and steel to be used must be defined. This is 

done in Job > General data. 

 

Figure 89 

Due to the façade of the warehouse being supported by the tie beams, the soil below them 

is compacted. Click on Job > Options > Tie beams and a dialogue box appears where the 

Surcharge due to soil compaction can be introduced. 

In this example, the weight of the concrete panel is of 2.7 kN/m2 (and has a height of 8m), 

therefore the surcharge to introduce, with its applied safety factor, is: 

qsc = 2.7 x 8 x 1.6 = 34.6 kN/m 

 

Figure 90 

Finally, when the foundations of a warehouse are designed, the main problems that arise 

are not related to the forces transmitted to the soil, but the weight of the element. The 
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internal pressures that occur due to wind suction, which combined with the small forces 

that descend down the columns, may cause uplift in the footings. As a result, very large 

footings may be provided in the design. 

Due to this occurrence, it is preferable, for this type of foundations, to start off the design 

with large initial footing depth dimensions. To do so, click on Job > Options > Pad footings > 

General tab and introduce a value of 50cm for the minimum depth. It is also convenient, in 

order to avoid this phenomenon, to return to the structure and introduce the load 

transmitted by the tie beams to the footings. In other words, a point load (dead load) acting 

in the negative Z direction, equal to the façade load supported by the tie beams is to be 

applied at each column start (the node defining the start of the bar). Then re-analyse the job. 

 

Figure 91 

 

3.13.4 Foundation design and check 

Having carried out the previous steps, the foundations can be designed. To do so, return to 

the Foundations tab and click on Analysis > Design. After the design process, elements 

containing errors will be displayed in red. By moving the cursor over the footing or beam of 
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the job, an information window appears indicating the design data of the footing 

(dimensions, reinforcement, bearing pressures and forces) or beam. 

 

Figure 92 

The program allows for each element to be edited, checked and designed using the option 

Foundation elements > Edit. 

3.13.5 Matching 

The pad footings are to be matched to obtain more homogenous results. To do so use the 

option Foundation elements > Match. 

Once the option has been activated, select the Master footing. It will be displayed in brown 

and all which are the same as it. The remaining footings will be displayed in yellow. Click on 

all the footings of the internal frames to match and once concluded, click on the right 

mouse button. 
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Figure 93 

3.14 Results 

3.14.1 Drawings 

Having designed the structure and its foundations, the job drawings can be obtained, To do 

so click on the  button which is located in the Foundations and Structure tabs. Once 

clicked on, the Drawing selection dialogue box will appear. 

 

Figure 94 
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Drawings can be added within this window by clicking on the  button and selecting the 

type of drawing from the Drawing editor dialogue box. In this case select a 3D Structure 

drawing. 

In this case, select a 3D Structure drawing and select to view the axis of the sections, the 

dimensions, section type and node references. 

Add three new drawings: Joints, Foundation floor plan and Foundation layout plan. 

Add another three new drawings. For the first select Joints, for the second Foundations floor 

plan and for the third Foundations layout plan. 

 

Figure 95 

Specify the peripheral to which the drawings are to be launched and click on Print. 

 

3.14.2 Reports 

3.14.2.1 Structure report 

The program has two options available regarding reports of the structure: the first option 

provides a report of all the structure, and the other, provides a report on only those 

elements that have previously been selected. 
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Report on all the structure 

The option for the report of all the structure  is located to the left of the drawings 

option. Upon clicking on this option, a window appears with a tree menu containing a box 

at each of its branches, which when activated displays the elements that will appear in the 

report. 

 

Figure 96 

Reports on a selection of elements 

This option is available within the Job menu in the Structures tab. Upon activating it, users 

must select the bars or nodes for which the report is to be produced. Once selected, click 

on the right mouse button to validate the selection and the window will appear in which 

the chapter and sections to be included in the report are to be indicated. 

 

3.14.2.2 Foundations report 

To obtain a report on the foundations, click on the Foundations tab and then select the  

button. 

 

 


	CYPE 3D - Practical example

	Contents

	1 Introduction
	2 Portal frame generator
	2.1 Loads generated by the program
	2.1.1 Dead loads
	2.1.2 Live loads
	2.1.3 Wind loadcase
	2.1.4 Snow loadcase


	3 CYPE 3D
	3.1 Node and bar introduction
	3.1.1 Layer management
	3.1.2 Show/hide planes
	3.1.3 Bar introduction and dimensioning

	3.2 Node and bar description
	3.3 Section layout
	3.4 Grouping of equal bars
	3.5 Materials
	3.6 Fixity coefficients
	3.7 Loads
	3.7.1 Add loadcase
	3.7.2 Panel loads: panels and surface loads
	3.7.3 Wind loads

	3.8 Buckling
	3.9 Lateral buckling
	3.10 Analysis and design of the structure
	3.10.1 Check bars
	3.10.2 Force consultation

	3.11 Joints
	3.11.1 Generate joints automatically
	3.11.2 Define joints manually
	3.11.3 Editing the joint

	3.12 Baseplates
	3.13 Foundations
	3.13.1 Footing introduction
	3.13.2 Tie beam introduction
	3.13.3 Data definition before the design
	3.13.4 Foundation design and check
	3.13.5 Matching

	3.14 Results
	3.14.1 Drawings
	3.14.2 Reports
	3.14.2.1 Structure report
	3.14.2.2 Foundations report




