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1.1. Introduction
The fundamental aim in the design of a distribution network
is for the gas to reach its consumption point. The problem
can be tackled from two different points of view:

• Design
This is the most usual case. Based on a set of
consumption data, the adequate diameters required
for the gas duct pipes are obtained.

• Check
Based on a designed installation, it is to be checked
whether it complies with the imposed design limits or
those considered by the designer.

Regardless of which of the two tasks is being carried out (des-
ign or check), the following points must be taken into account:

• The arrival conditions of the gas at the consump-
tion points. A series of conditions must be respected
such as consumption pressures or its velocity.

• Ease of construction. Use materials, diameters and
other elements that are easily available on the market,
that comply with standards regarding their dimensions
and behaviour.

• Maintenance. Ensure the installation operates well to
avoid excessive and expensive corrective mainte-
nance, which in turn, contributes to the preventive
maintenance of the installation.

• Economy. The installation not only has to work, it
must also operate at a reasonable cost and over-des-
igning should be avoided. Once all the necessary data
has been collected, the analysis will be carried out
using the adequate formulae for each case.

1.2. Initial data

1.2.1. Supply conditions

Data on the supply conditions are required when designing
an installation. This data will mark the behaviour of the ins-
tallation.

1.2.1.1. Consumptions

This is what generally determines the operation of the ins-
tallation. The flow to be supplied at each node of the instal-
lation is usually estimated based on the type of supply (ur-
ban, industrial, commercial…) and the climate zone. Optio-
nally, the consumption at a specific node can be expres-
sed, for fuel gases, by stating the heating power required at
that node, for which the higher heating value of the gas will
have to be provided.

As a guide, the most common values used in projects are
displayed in the tables below:

1. Gas supply design
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For appliances:

For industrial consumption or large commercial surface
areas, the total consumption will be calculated by adding
the consumption of each appliance without applying any
simultaneity factors.

Furthermore, not only the current residents of the zones to
be developed are to be taken into account, but also foresee
the possible increase in population that will, in the future, be
supplied with gas from the network that is being designed.

To obtain a rough estimate, the future population can be
calculated as:

where:
P: Future population
Pa: Population from the last census
α: Growth rate of the population
t: Time elapsed since the last census

In some cases, it may be interesting to apply a coefficient
which generally increments or reduces, the consumptions
of a network. This way seasonal variations or lower occu-
pancies can be simulated. This coefficient is only applied to
the flow consumed at the nodes and during the analysis.

1.2.1.2. Distributed consumptions

In special cases, it may be very useful in the design to si-
mulate the consumption points of the installation and distri-
bute these linearly along the span of the pipe.

This provides an initial design estimate for installations with
similar consumption points along a span of the pipe.

Using the results diagrams, users can see the point as of
which the pressure requirements that are established for
the job are not met, so the span can then be divided into
two spans with more adequate diameters.
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The flow consumption or uniform power must be indicated
in units per linear metre of the pipe.

1.2.1.3. Supplies to the network

A gas network receives its supply at one or several points.
These points receive gas from the supply company or from
other networks which are capable of supplying gas to the
installation. The supply company must indicate, in each
case, the value of the supply pressure as well as the mini-
mum pressure to be obtained at the consumption points.
As a matter of fact, two supplies with different pressures
can cause the gas to circulate between them due to the dif-
ference in pressure. If a sufficiently large load does not
exist between them to reduce this difference, the gas can
be transferred from one to the other. To avoid this circula-
tion, the following measures can be taken:

• Avoid, if possible, placing a large number of supply
nodes. If several supply nodes have to be provided,
they should be as far away from each other as possi-
ble.

• Avoid large differences in pressure between the supply
nodes. It can be assumed that the distribution com-
pany is sufficiently large and has been designed to pro-
vide similar pressures at all points.

It may occur, however, that users may wish to design
the installation with gas circulating between supply
points, but they must bear in mind that this type of be-
haviour may adversely affect the design of the ducts.

1.2.1.4. Velocity in the ducts

One of the main limits when designing a gas duct network
is the velocity of the fluid within them. It is not recommen-
ded a velocity exceeding 20 m/s be used, even though Re-
nouard’s formula is valid up to 30 m/s.

1.2.1.5. Pressure at the consumption points

When a gas supply network is designed, the minimum
pressure at the consumption points must be ensured. This
depends on the supply pressure and the requirements of
the appliances.

1.2.2. Ducts

The behaviour of a gas supply network greatly depends on
the size and type of ducts that are used.

1.2.2.1. Materials

Due to the low density of the gases circulating in the net-
work, the effect of the materials and their finishes can be
neglected, and are only taken into account for identification
purposes.

1.2.2.2. Diameters

The materials used for the jobs are contained in material li-
braries. A series of diameters is available for each material.
These libraries can be defined by users and can be edited
to remove or add diameters to the series.

For each material, there is a standard predefined diameter
series. These are usually labelled with ‘DN’ alongside their
approximate diameter in millimetres.

It is common practice in gas installations to state the duct
sizes in inches, although it must also be noted that the
number of inches does not indicate the exact size of the in-
ternal diameter and must be taken as a reference.

Larger diameters cause smaller losses in the ducts and re-
duce the circulation velocity, but increase the cost of the
installation.
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1.2.2.3. Special elements

Due to the construction or control requirements, gas supply
installations require other special elements as well as
pipes.

To be able to take into account the losses incurred in these
elements, it is common design practice to increase the
physical length of the ducts by a certain percentage, so to
obtain a resistant length which includes these localised
losses.

To do so, a resistant length increase percentage can be
defined to simulate these losses. This length increase is
only applied during the analysis and not for the quantities
of the pipe. The recommended increase, in practice, is
20%.

1.2.3. Excavations

Distribution and urbanisation gas duct installations are
usually buried. To do so, trenches are excavated to carry
the ducts. It may be interesting to consider the shape, ex-
cavation volume and other factors when designing the ins-
tallation.

1.2.3.1. Soil properties

The way in which the trench will be excavated depends on
the properties of the soil where the duct will be buried. The
properties of the soil to be excavated should be known as
well as some properties of the duct installation process:

• Slope. This is the maximum inclination the soil surface
can have without it breaking down. It is usually indica-
ted as the number of horizontal metres per vertically ex-
cavated metre.

• Lateral distance. Minimum distance between the duct
and the walls of the trench.

• Minimum width. Due to some mechanical limitations,
excessively narrow trenches cannot be excavated. If the
duct has a small diameter and, having added the lateral
distances, the total width does not exceed the minimum
width, the minimum width will be taken as the design
width.

• Bed. Distance between the ground of the trench and
the bottom of the duct. It usually consists of a sand infill,
although there are also concrete infills in some cases.

• Infill. Once the duct has been placed on the bed, it is
filled with sand until the duct has been covered. The in-
fill distance corresponds to the thickness of the sand
layer above the duct.

1.2.3.2. Measurements

In order to carry out the design of the excavation, informa-
tion is required on the excavation depths. The following in-
formation must be provided:

• Node elevation. This is the elevation of the bottom part
of the duct of each node of the installation.

• Soil elevation. This is the elevation of the modified soil,
i.e. the flat soil which is going to be excavated.

• Ground level elevation. This is the elevation of the
surface once the trenches have been closed and the
road surface has been laid on the ground.

The thickness of the road surface is usually constant for the
entire job, so only the ground level elevation is required and
the soil elevation is taken as the ground level minus the
thickness of the road surface. If there is no road surface
(thickness = 0), the ground level elevation will be the same
as the soil elevation.
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All this is applicable to new jobs. If the job model consists
of repairs or modifications of existing roads, there may be
differences in the measurements due to there being two
layers with different excavation properties.

1.2.3.3. Limits

Due to the situation of the installations (electricity, water,
gas, telephone...) below ground level, there are usually mi-
nimum depth limits that have to be respected to avoid any
collisions with the other installations.

This minimum depth is measured from the ground level
elevation to the top surface of the duct.

By respecting these minimum depths, accidental damage
to the duct will be avoided in future excavations.

1.3. Analysis (Analyse option)
Once the initial data has been collected, the installation is
analysed, in accordance with the types of ducts, diame-
ters, required flow and supply pressures. To do so, the for-
mulae and method detailed below are applied.

1.3.1. Formulae

The discrete finite element method is used to solve the sys-
tem of equations of gas installations, be they mesh, bran-
ched or mixed networks.

If the node consumptions are provided in heating power
terms, the flow is obtained using the following formula:

where,
Q: Required gas flow at the node (m3/h)
P: Required heating power at the node (W)
PCS (HHV) : Higher heating value of the gas (W·h/m3)

In the design process of each segment of the installation,
the drops in pressure between two nodes connected by a
span are calculated using Renouard’s formula:

where:
P1, P2: Absolute pressures of the gas at the initial and final
points of the span (bar)
CRl: Constant coefficient of Renouard’s linear formula. Its
value is usually taken as 23.2
CRc (CRq) : Constant coefficient of Renouard’s quadratic
formula. A value of 48.66 is usually taken for pressure bet-
ween 0.1 and 4 bar, and 51.5 for pressures up to 16 bar.
ρr: Relative density of the gas used. For natural gas, this
value ranges between 0.55 and 0.65
L: Resistant length of the duct (m)
D: Internal diameter of the duct (mm)
Q: Flow circulating through the duct (m3/h)

The velocity is calculated using:

where:
Cv: Is a constant factor. Its value is usually 354, although for
pressures exceeding 4 bar, a value of 378 is taken
Z: Gas compressibility factor. For values below 5 absolute
bar, a value of 1 is usually considered.

Renouard’s formula provides the same flow value whether
P1 is equal to 1 bar and P2 equal to 0.5bar, or if P2 is equal
to – 0.5 bar. Renouard’s quadratic formula has a zone for
which it is not defined biunequivocally, and so its evolution
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is not valid. For this zone, the value of one of the two pres-
sures can be approximated by weighting the values from
the quadratic and linear formulae, and so the results can-
not be considered as being reliable. This value can only
provide a rough idea of whether the difference in pressure
of the established limit is large or small.

Renouard’s formula is valid for values below 30 m/s. For
greater velocities, the results are for guidance only.

1.3.2. Ducts with distributed consumption points

To design a span with uniform consumption rates, the re-
quired flows or powers per linear metre are discretized at
small consumption points.

By introducing this discretization, the number of nodes of
the installation increases, and hence, the number of equa-
tions of the system also increases. This implies an increase
in the time required to analyse the job, similar to that requi-
red due to the manual introduction of each of the nodes
generated by this discretization.

Once the solution of the system of equations have been
obtained for the sub-spans, a flow and velocity are obtai-
ned, which vary linearly with the length of the span, as well
as the corresponding pressure curve, which can vary de-
pending on whether or not the duct has a supply of flow at
either end, etc.

This latter case, which contains flow in both directions, will
have a point with null flow and velocity, which corresponds
to the minimum pressure (maximum drop in the span).

1.3.3. Solving a mesh system

To solve a mesh system, a variant of the discretized finite
element method is used. The model of the duct is taken as
a stiffness matrix [K] for each element in the network:

where:
G(e) is the factor which, linearly, relates the drop in pressure
of element ‘e’ with the circulating flow. The stiffness matri-
ces of the installation are then assembled into one single
matrix, which is solved by frontal methods.

Thanks to this method, mesh, branched or mixed systems,
with one or two fixed pressure supply points can equally be
solved.

1.3.4. Design (Design option)

If, after the analysis, there are spans or nodes which do not
comply with all the imposed limits, an automatic optimum
design can be run. Due to the complexity of the behaviour
of mesh systems, together with the lack of linearity and the
iteration needs required by gas installations, the design
must be carried out using the trial and error method.

During the initial design, the program will try to optimise
and select the minimum diameter that complies with all the
restrictions (velocity, pressure).

At the start of the design, the smallest diameter belonging
to the assigned material series is established.

This first iteration provides a series of deviated values of
the established velocity and pressure limits. The diameter
of the span in worst condition, i.e. the span whose velocity
most exceeds the velocity limit, is then increased.

Once all the spans meet the conditions, the nodes are
checked to ensure they all comply with the minimum pres-
sure requirements. If there are any nodes that do not com-
ply, the diameter of the most loaded ducts, i.e. those with
greater header loss per unit, is increased.
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1.3.5. Units

The program requires the data to be introduced in a series
of units, which are needed internally so to apply the requi-
red formulae. The units used are displayed in the table be-
low:
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A design example of a gas network can be seen in the fol-
lowing pages. We recommend it be followed step by step
to learn how to manage the program. The following dia-
gram displays the distribution of the plots for which the
design will be carried out.

Fig. 2.1

This job example is included with the program. To access
it, following these steps:

• Open the program.

• Click on File > File manager. The file selection window
will open.

• Press the Examples button. Now open the job file,
which can be found at: \CYPE Ingenie-
ros\Examples\Gas.

The system consists of a mesh network. The population is
estimated based on the partial development plan of the
rea. 4 residents will be taken per dwelling.

The assigned flow per dwelling will be D = 1.2 m3/h.dwell.
The assigned flow for the commercial area will be 60 m3/h
and 40 m3/h for the academic area. The network will be
built using polyethylene piping, starting with a diameter of
63 mm. The basic loadcases to be used in the design are
'Dwellings' and 'Commercial and academic zones'. The fol-
lowing design combinations are:

1. Dwellings. With the corresponding flow assigned to all
the dwellings.

2. Dwellings + Commercial and academic zones.
With the flow assigned to all the dwellings and to the
commercial and academic zones. The gas network is
displayed in this diagram:

2. Gas Supply Example
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Fig. 2.2

2.1. General data
Select File > New. The New job window will appear on
screen. Introduce a name for the job. Upon accepting, the
General data window for the installation will open.

2.1.1. General folder

Begin introducing the general data of the installation: title,
location, population, date and comments.

This general data will appear in the design reports of the
installation.

Fig. 2.3

Click on the Materials button to select those that will be
used in the job. Select the material displayed in the follo-
wing figure from the CYPE library and press the but-
ton to use it as a material for the job.

Fig. 2.4
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Click on the Soil button to select the type of soils that will
be present in the job. Select the type displayed in the follo-
wing figure of the CYPE library and press on the but-
ton to add it to the Soils of the job list.

Fig. 2.5

2.1.2. Parameters folder

The consumption shall be introduced as a flow instead of a
heating power. The service pressure will be of 0.1 bar. The
relative density of the gas will be 0.62. The constant coeffi-
cient for the linear Renouard formula will be 23.2. The
constant coefficient for the quadratic Renouard formula will
be 48.6. The constant for the gas velocity formula will be
354. The compressibility coefficient of the gas will be 1.

2.1.3. Limits folder

The maximum velocity in the spans will be 20 m/s. The mi-
nimum pressure at the nodes will be 0.09 bar.

2.1.4. Coefficients folder

The simultaneity coefficient will be 1. The length increment
coefficient will be 20%. The load will be introduced in terms
of assigned flow and will be 1.2 m3/h (per dwelling). The
prefix for a consumption node will be NC, for a supply node
SG and for a transition node N.

2.1.5. Excavations folder

The minimum depth of the duct will be 0.70 m, and the
thickness of the road surface 0.35 m. Activate the Display
excavation parameters box.

2.2. Loadcases
The loadcases, combinations and coefficients that will inter-
vene in the design of the network were specified in the first
pages of this chapter.

Press General data > Edit loadcases. Configure the sim-
ple loadcases described below.

Fig. 2.6
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2.3. Combinations
Click on General data > Edit combinations. A window
will open where the name is to be indicated of the combi-
nations and combination coefficients to be used for each
loadcase. Place the values indicated in the combination
coefficients table for the simple loadcases described in the
first pages of this chapter.

Fig. 2.7

2.4. Geometry introduction
The easiest way to introduce the geometry is by using a
DXF or DWG file as a template. To install the DXF of this
example in the hard drive, click on File > Import > Insta-
llation examples. Now to import the DXF file to the pro-
gram’s own format, follow these steps:

• Select the Edit templates icon from the toolbar. The
DXF-DWG view manager window will open.

Fig. 2.8

• Click on the Add icon. The DXF-DWG selection win-
dow will open. Select DXF and search for the following
file:

\CYPE Ingenieros\Examples\gas\gas.dxf.

Select it and press Open.

Fig. 2.9
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• Click on Accept to return to the DXF-DWG view ma-
nager window, then press Accept again to view it on
screen.

Fig. 2.10
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To use the object snaps, click on Template object snaps in
the toolbar and activate, for example, Intersection or End.

Fig. 2.11

Introduce the spans using the Spans > New option, and
by using the template. Even though the nodes in the figure
below are displayed with a different set of references, the fi-
nal references have been displayed so they may act as a
guide for when the nodes will be edited at a later stage (Fig.
2.12).

Nodes are created as transition nodes by default, in other
words, nodes without consumption which allow for
changes in the direction to be carried out but maintain the
span joined in the design.

Fig. 2.12
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2.5. Edit nodes
Click on Nodes > Edit design data. Introduce the data of
the following figure at general supply node (SG1).

Fig. 2.13

The load of consumption node NC1 is defined by its assig-
ned flow. In the Loads table, click on the Edit button of the
corresponding loadcase, in this case ‘Dwellings’, in the
Flow column (l/s).

The assigned flow is indicated in General data > Coeffi-
cients, and is 1.2m3/h. The number of units is the number
of dwellings to be supplied per node; in this case 14. The-
refore, click on Edit and introduce the following data:

Fig. 2.14

Introduce the remaining nodes as ins indicated in figure
2.2.

Nodes can be introduced in a very practical manner using
the Nodes > Assign design data command.

2.6. Edit spans
Even though the default data will be left for this example, if a
span is to be modified, use the option Spans > Edit design
data, which will open the dialogue box displayed below.
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Fig. 2.15

A window opens in which the specific data of the span will
be introduced, and so can be different to those defined in
the General data. Click on the help button for more informa-
tion.

Spans can be introduced in a very practical manner using
the Spans > Assign design data command.

2.7. Analysis
To analyse the installation, click on Analysis > Analyse.
The program will check the network applying the dimen-
sions that have been indicated.

Once completed, a report may appear indicating the errors
that have arisen during the analysis.

Fig. 2.16
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The analysis process does not stop at any moment, if a
possible solution can be found.

After the analysis, the program will display the maximum
envelope will be displayed. Nodes and spans failing
checks will be displayed in red.

Using the data and results of the different load-
cases, combinations and envelopes can be viewed. Enve-
lopes will only indicate if the span passes or fails checks.

To know the reason why a node or span fails a check, a
combination must be activated. A colour key is displayed
which identifies the nodes and spans with its limits.

A text is displayed in the bottom part indicating the name of
the job and the loadcase, envelope or combination cur-
rently being viewed.

To consult the resulting data from the analysis of each node
or span for each combination, click on the Information
button in the Nodes menu or in the Spans menu.

Once all the design results have been checked for spans
and nodes, the necessary modifications, manually or auto-
matically, will have to be carried out to adjust the network.

If, after the analysis, there are spans or nodes which do not
comply with all the limits that have been imposed, an auto-
matic optimum design can be carried out.

Click on Analysis > Design. The program will ask if you
wish to assign the results of the pre-design to the current
job. If Yes is pressed, the installation will be analysed using
this design.

Fig. 2.17
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2.8. Reports and drawings

2.8.1. Reports Reports can be obtained by pressing
on File > Print > Job reports.

The reports can be sent to a printer (with optionally prelimi-
nary view, page adjustment, etc.) or can be generated in
HTML, PDF, RTF and TXT format.

Fig. 2.18
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2.8.2. Drawings

Drawings can be obtained by pressing on File> Print >
Job drawings. The following operations can be carried out
to obtain drawings:

• The Drawing selection window allows for one or seve-
ral drawings to be added to be printed simultaneously
and to specify where it is to be sent: printer, plotter, DXF
or DWG; select a frame (CYPE defined or any other
user defined frame) and configure layers.

Fig. 2.19

• Configure the elements to be printed for each drawing,
with the possibility to add details that have been pre-
viously defined by users.

Fig. 2.20

• Modify text positions.

Fig. 2.21

• Relocate objects within the same drawing or move
them to another.



Gas Installations - User manual 23

CYPE

CYPE programs have on-screen help tools to provide users
with the necessary information on the program menus, dia-
logue boxes and options.

There are four different ways to access the help icons:

3.1. Pressing F1
To obtain some help on a menu option, open the drop-
down menu, place the cursor on the option and without
executing it, click on F1.

3.2. Question mark icon
A question mark icon can be seen in the title bar of the
main window of each program. Specific help on a program
option can be obtained the following way: click on the
question mark icon then unfold the menu containing
the option for which the help is sought and click on the op-
tion. A window will appear containing the required informa-
tion. This option provides the same information as when
the F1 key is pressed.

This help can be deactivated in three ways: by clicking on
the right mouse button, by clicking on the question mark
icon or by pressing the Esc key.

You can equally obtain information on the toolbar icons.
Upon selecting the question mark icon , the icons will
be highlighted in blue. By then clicking on the icon, the help
information will be displayed.

3.3. Book icon
Within the title bar of several windows, an open book icon

can be found which, upon clicking on it, will display ge-
neral information on the contents of the window.

3.4. Quick guide
The option information displayed using the F1 key can also
be consulted and printed out by selecting Help > Quick
guide. These explanations are those corresponding to the
options found within the screen tabs.

The explanations in the dialogue boxes are different to
those of the guide.

3. On-screen help
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