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Portal frame generator 
User’s Manual  
Geometric generator of rigid portal frames and simple and 
multiple trusses. Automatic generation of wind and snow 
loads. Design and optimisation of roof and lateral purlins. 
Exports the geometry and loads to the program CYPE 3D. 



 
 
 

Contents 
1 Calculations ............................................................. 3 

2 Program description ............................................... 4 

2.1 Frame creation .................................................................. 4 

2.2 Types of frames ................................................................ 5 

2.3 Drawings and Reports ..................................................... 7 

3 Example.................................................................... 8 

3.1 Problems to solve ............................................................. 8 

3.2 Data introduction ........................................................... 10 

3.3 Defining the geometry ................................................... 13 

3.4 Purlins .............................................................................. 18 

3.5 Warehouse data report ................................................. 22 

3.6 Drawing of the frame ..................................................... 23 

3.7 Exporting to CYPE 3D ..................................................... 24 

 



 

 

 

User guide Portal frame generator /  3 

1 Calculations 
The loads due to climatic conditions applied to the frames are calculated in accordance 
with what is indicated in the selected code. 

When designing the purlins, the program uses the continuous beam model with a variable 
number of spans, defined by the user. The program calculates the stresses and deflections 
in accordance with the selected code. 

The purlins are checked so they do not fail due to maximum deflection or stress. 
Additionally, in the case of rolled steel sections, checks are undertaken for lateral buckling, 
and in the case of cold-formed sections checks for warping and buckling are included as 
part of the stress checks as contemplated in the corresponding code. 

Therefore, with this program, the user can safely design both roof and lateral steel purlins 
for warehouses. 

The program only allows for the design of parallel and equidistant frames, hence only one 
value is sought to establish the distance between the frames. 

The geometry in two or three dimensions can also be generated, as well as defining the 
applied loads and buckling coefficients so to continue with the warehouse design in CYPE 
3D. 

Other properties of the program worth highlighting include: 

• Generation of wind loads in accordance to a range of design codes. 

• Generation of snow loads in accordance to a range of design codes or simply apply a 
generic snow load. 

• A library containing cold-formed, rolled and welded steel sections, which may be edited 
and is compatible with CYPE 3D. 

• Report of data introduced and design results. 

• Drawing composition using the configured peripherals. 

• Stress design in accordance to a range of design codes. 
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2 Program description 
2.1 Frame creation 

Upon creating a new job and introducing the data of the job, the program inquires if a new 
frame is to be introduced. 

If the user replies No, the screen remains empty however, later on, the user may click on 
the screen area and introduce a new frame. If the user selects Yes, a window appears 
where the user may choose between a mono pitch frame or a dual pitch frame. 

If the option Mono pitch is selected, the Mono pitch portal frame generation dialogue box 
will open. If the Dual pitch option is selected, the dialogue box shown in Fig. 2.1 appears. 
Either of the two dialogue boxes contains the geometrical data of the frame. 

 

Fig. 2.1 

Within the window that appears, the user is to select the type of roof the frame is to have. 
Having done so, the dimensions and data presented by the program may be modified. 

Once this window has been accepted, the program will display the defined configuration 
on screen. By clicking in the middle of the screen, the Edit menu appears whereby the user 
can insert, edit, delete, etc. This menu may also be accessed, but with different options by 
clicking to the left of the first frame or to the right of the last frame. 
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2.2 Types of frames 
Displayed in the following table are the types of frames available with the program. 

 

Fig. 2.2. Available types of mono pitched roofs 
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Fig. 2.3. Available types of dual pitched roofs 
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Fig. 2.4. Available types of dual pitched roofs 

 

2.3 Drawings and Reports 

2.3.1 Reports 
The program provides reports on the job data introduced, checks carried out on the 
purlins, their take off, and the loads on bars. 

The reports are obtained by clicking on File > Print > Job Report. 

The reports can be sent to a printer (with optional page preview, page setup, etc.) or 
alternatively generated as HTML, PDF, RTF or TXT files.  

 

2.3.2 Drawings 
Drawings can be obtained by clicking on File > Print > Job Drawings. 
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3 Example 
3.1 Problems to solve 

The object of this manual is to teach the user how to use the program by designing a steel 
warehouse. 

The Portal frame generator carries out the following tasks: 

1. Designs the roof purlins 

2. Designs the lateral purlins 

3. Generates the design specifications 

4. Provides drawings of the frame with its purlins 

5. Generates the structure in CYPE 3D so the remaining bars may be designed. 

3.1.1 Preliminary data 
The example that has been chosen consists of a warehouse composed of three different 
adjacent frames. 

The first is a single sloped frame with a 10 m span. The second frame is a straight Fink truss 
with a 30 m span and 10 m in height. The third frame is a dual pitch frame with a 16 m 
span and 8 m height. The warehouse contains 7 sets of  frames at 7 m intervals. 

3.1.2 Loads 
• Dead loads 

- Self weight of the purlins 

- Roofing material (sandwich panel composed of galvanised sheet with polyurethane 
foam: 0.12 kN/m2) 

• Live loads: 

- Assume a live load of 0.4 kN/m2 

• Wind action: 

In accordance with EC1 

• Snow loading: 

 In accordance with EC1 
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For this example the warehouse will be assumed to not have any openings. 

 

 

3.1.3 Frame geometry 
The geometry of the warehouse to be studied is generic and contains several types of 
frames. This way the user can become familiar with nearly all the options of the program. 

 

Fig. 3.1. General view of the warehouse 

 

  
Fig. 3.2. Dimensions of the main frame section 

N.B.: The weight of the purlins does not have to be added to the dead loads; the program 
will automatically calculate their applied self weight upon exporting to CYPE 3D. 
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3.2 Data introduction 
In this section, the data defining the warehouse is introduced. 

3.2.1 Creating a new file 
Upon opening the program, the job which was previously being worked on will 
automatically appear. If a job has not been created yet or the last job which was being 
worked on did not have any defined frames, a window will open prompting the user on 
whether a new frame is to be introduced.  

If Yes is selected, the program will guide the user through a series of steps to introduce the 
frame. 

If the option No is selected, the dialogue box will close and the user can then click on File > 
File manager so to select a saved job or on File > New to create a new job. 

If this window appears, answer No. Then click on File > New. If the last job or example 
appears, click on File > New to create a new job. 

A window will open prompting the user for a name (Example). 

 

Fig. 3.3.  

 

3.2.2 General data of the job 
Having confirmed the name of the job, the Job data window will open (can also be 
accessed by clicking on Job data > General job data). 

Introduce the following data: 

• Number of spans: 7 

• Distance between frames: 7 m 

• Roof covering. Activate the With roof covering box. Two further options will appear: 

- External wall weight: Introduce a value of 0.12 kN/m2. 
- External wall live load: Introduce a value of 0.40 kN/m2. 
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• Lateral wall covering. As the warehouse has external walls, activate the With lateral 
covering box and introduce a value of 0.12 kN/m2 for the external wall weight. 
 
For the wind load, select Eurocode 1, reference speed 26 m/s, terrain category Single 
and IV, Flat land in the X and Y directions and a service period of 50 years. 

 

Fig. 3.4 

For the snow loads, select Eurocode 1, United Kingdom, Republic of Ireland, Zone 3, 
Normal landscape and a topographic height of 0 m. 

 

Fig. 3.5 
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Fig. 3.6 

 

Fig. 3.7 

For the load combinations, select Building category E: warehouses and for the snow: 
Remaining CEN Member States, H ≤ 1000 m. 

 

Fig. 3.8 

The Job data window should be as shown below: 
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Fig. 3.9 

3.3 Defining the geometry 
Description of Frame 1 
Upon accepting the Job data window, the program will ask ‘Do you wish to introduce a new 
frame?’. Click on Yes. 

Another dialogue box will appear asking whether the frame is to consist of a mono pitched 
roof or dual pitched roof. Click on Mono pitch. 

 

Fig. 3.10 

Within the Mono pitch frame generation dialogue box, select Rigid frame and change the 
dimensions in the diagram: 

• Height of the left column: 5 m 
• Height of the right column: 7 m 
• Span: 10 m 

 

Fig. 3.11 
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To change the dimensions, click on the displayed value and type in the new dimension. 
Click on Accept to close the description window for the first frame. 

 

Fig. 3.12 

To generate or modify a frame, click on the central area of the screen. A new window will 
appear displaying all the edition options. 

Description of Frame 2 
Click to the right of the first frame. The Edit menu is displayed. 
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Fig. 3.13 

Click on New frame and the dialogue box enquiring whether a mono pitch or dual pitch 
roof is to be introduced appears.  

Select Dual pitch and from the Dual pitch frame generation window, select a Straight Fink 
truss. Introduce the following data: 

• Height of the left column: 10 m 
• Height of the right column: 10 m 
• Height of the ridge: 13 m 
• Half-span to the left: 15 m 
• Half-span to the right: 15 m 
• Internal spans on left: 8 
• Internal spans on right: 8 
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Fig. 3.14 

Description of Frame  
Repeat the same creation process as with Frame 2, only now with the following data: 

• Dual pitch roof 

• Rigid frame 

• Height of the left column: 8 m 

• Height of the right column: 8 m 

• Height of the ridge: 10 m 

• Half-span to the left: 8 m 

• Half-span to the right: 8 m 

 

Fig. 3.15 
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Once the geometry of Frame 3 has been defined, the global image of the complete frame is 
obtained: 

 

Fig. 3.16 

 

Description of the lateral walls 
The warehouse has an external wall to the right measuring 2 m in height. To introduce this 
data, click to the right of the last frame. 

From the Edit menu that appears, select Lateral wall. Activate the option With perimeter 
wall with a height value of 2 m and activate the Braces the column against buckling and 
Self-balanced options. 

 

Fig. 3.17 

By selecting this option, the program assumes the lateral wall braces the column against 
buckling outside the plane of the frame, hence modifying the corresponding buckling 
lengths. This option should only be activated when the user is sure this bracing will be 
effective.  
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3.4 Purlins 
The program incorporates an easy to use purlin design tool for roof or lateral purlins. Click 
on Job data > Lateral and roof purlin edition.  

 

3.4.1 Roof purlins 
Before designing the purlins, the user has to confirm or modify the data regarding their 
design: 

 

Fig. 3.18 

Deflection limit 
This parameter establishes the maximum deflection criteria for roof purlins depending on 
their span. For this warehouse, leave the default value of L/250, which is the value that is 
usually taken for roof beams or joists. 

 

Number of spans 
The program calculates the purlins as if they were a continuous beam. To obtain the 
correct forces and lateral buckling lengths, the number of spans they cover has to be 
indicated. 

 

 

This number is not the total number of spans the whole warehouse will have; it is the 
number of spans one purlin will cover. If the various spans of the purlins overlap at their 
ends, the transmission of forces is continuous, hence, the purlin will cover the same 
number of spans as the entire warehouse. For this example, select Three or more spans. 
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Type of attachment (roof) 
Depending on the type of roof that has been chosen, the program applies the loads for 
which the purlins are checked with. It can be one of the following three cases: 

• Case 1: Non-collaborating roof. Asbestos cement roofs do not collaborate bracing or 
holding the purlins. Hence, they will have to be designed for the worst case 
combination including any torsion that may arise due to the eccentricities of the 
applied loads. In this case only rolled sections may be used. 

• Case 2: Hook fixing. The roof is assumed to be infinitely rigid in its plane and therefore, 
the purlins only have to resist flexure in the plane normal to the roof. If they are 
attached using hooks, the torsion due to wind suction must also be resisted. Any 
warping is considered to be negligible.  

• Case 3: Rigid fixing. Similar to the previous case, only here, the program assumes the 
roof prevents the purlins from rotating and so there is no torsional moment. The only 
forces they have to resist are the bending moment and shear force in the plane 
perpendicular to the roof.  

For this example, select Rigid fixing.  

 

Type of section 
Here the section series and specific section to be used on the roof is selected. The default 
section that is shown corresponds to the first section that appears in the section library. 
For this warehouse example, click on the button displaying the section and the following 
window appears: 

 

Fig. 3.19 
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Once again, click on the name button of the default section. In the next window, select the 
following options: 

• Material: cold-formed 

• Section data: In job series 

• Section series: Cold-formed Z 

• Selected section: ZF-10x2.0 (default section) 

 

Fig. 3.20 

It may occur that the cold-formed sections are not visible in the drop down menu. This is 
because the section series has not been imported from the section library. To import it 
click on the Library Management button and select the library series to open. 

 

Separation 
This is the separation between the purlins to check. The default value is 1 m. 

 

Steel type 
This option refers to the type of steel used for the purlins whose elastic limit establishes the 
maximum stress criteria and affects stability checks (warping, buckling, etc.). Select S-275. 

 

Design 
To find the optimum purlin section and separation, use the third design button. Upon 
clicking on it, the Purlin optimisation window will appear, where the range for the optimum 
separation has to be established. In this case set the parameters so to find a solution 
between 1.5 and 2.0 m with an increment of 0.1. 
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Fig. 3.21 

Having accepted, the program runs through a design process and provides a list of the 
section sizes with their corresponding separations indicating whether or not they verify all 
the checks. Select ZF-225x4.0 every 2.0 m and Accept. 

 

Fig. 3.22 

 

The Section selection window will reappear displaying the selected section. 

 

Fig. 3.23 
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3.4.2 Lateral purlins 
Click on Job data > Lateral and roof purlin edition > Purlins on sides. The parameters 
and procedure are similar to the roof purlin definition. Introduce the following data: 

• Deflection limit: L/250 

• Number of spans: Three or more spans 

• Type of attachment: Rigid fixing 

• Section type: IPE-120 

• Separation: 1.2 m 

• Steel type: S275 

 

Fig. 3.24 

 

3.5 Warehouse data report 
To view and print a report of the data that has been introduced and designed for the 
warehouse, click on File > Print > Job report and accept all the chapters proposed by the 
program. 

The program will then present a preliminary view of all the information included in the 
report. The report can then be printed by clicking on the Print icon. The information can 
also be sent to the default Windows printer or exported as a text file. In this case the name 
of the file and creation directory can be modified. 
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Fig. 3.25. Extract of the example report. 

 

3.6 Drawing of the frame 
To draw the frame of the warehouse, click on File > Print > Job drawings. The Drawing 
selection window will open. 

 

Fig. 3.26 

Click on  to add a new element to the list. The user can modify the scale, text height, 
dimension text and add details to the window presented by the program. For this example, 
leave all the default options. 
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Fig. 3.27 

To finish off, accept the two windows. The Drawing composition window is generated 
displaying a preliminary view of the drawing. 

 

Fig. 3.28 

If the user is satisfied with the arrangement, click on Drawings > Print > Print all. The 
drawing will be sent to the selected peripheral. 

Please recall that CYPE 3D is a program which designs any structure made up of bars. To 
do so, it uses the matrix method. The process is especially designed for metallic elements. 

 

3.7 Exporting to CYPE 3D 
The last operation to be carried out consists of generating the structure in CYPE 3D. 

From the main display, click on Job data > Export to CYPE 3D. A dialogue box will open 
where the selected roof purlin has to be confirmed. Click on Yes. Then in the next window, 
confirm the selected lateral purlin. 
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The Options for exporting to CYPE 3D window will open. 

For this warehouse and to configure the type of support, select Fixed frames. This option 
refers to the type of support the columns will have. It also affects the buckling lengths.  

In the Buckling options section, activate Buckling in non-sway frames. 

For the Type of generation select 3D frame generation. 

For the grouping options activate Group central and end. 

To validate the options, click on Accept. 

 

Fig. 3.29 

The program will ask whether the user wishes to export. Click on Yes, and confirm the job 
is to be saved. The Portal frame generator will close and CYPE 3D will automatically open.  

Complete the series of initial options indicated by the program within the New job window 
that appears (these can be modified at a later date). The program will ask for the job to be 
assigned name (the name provided in the Portal frame generator will appear as the 
default option). Upon accepting, the global structure will appear. 
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Fig. 3.30 

The main steps that now have to be carried out in CYPE 3D are: 

• Describe the sections 

• Check the buckling coefficients with respect to the local xy plane 

• Check the moment coefficients for lateral buckling of the elements 

Describe the nodes to activate the design of pad footings and baseplates. 
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