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Presentation

CYPECAD is the software for reinforced concrete, steel, timber and aluminium structures which
provides the spatial analysis, structural element design, reinforcement and section edition, and construc-
tion drawings of the structure.

It carries out the analysis of three dimensional structures composed of supports and floor slabs,
including their foundations, and the automatic design of reinforced concrete, steel, timber and aluminium
elements.

With CYPECAD, the engineer holds a precise and efficient tool to resolve all the aspects related
to the analysis of the structure of any type of concrete as well as being adapted to the latest international
Codes.
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15.1. Introduction
Two practical examples are described below. Each exam-
ple is approached in a different manner. There is no single
correct way to introducing a job. With practice, the user will
develop his or her own method of introducing and analy-
sing a job. Nonetheless, the objectives of both the exam-
ples are to:

• Act as guides as to how the data of the structures
should be organised.

• Show how they are to be introduced in the program.

• Analyse their results.

• Obtain the necessary drawings and reports.

15.2. Example 1
In this example, a reinforced concrete structure composed
of columns, beams and joist floor slabs is to be introduced.

Fig. 15.1

N.B.: A more advanced course is available, published by
CYPE : Practical course of CYPECAD, which can be stu-
died once this example has been worked through.

The following practical example is included with the pro-
gram. To access it and install the DXF file to be used as a
template for the data introduction, follow the following
steps:

15. Practical examples
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• Open the program

• Click on File > File manager. The file manager win-
dow will open.

• Click on the Example button.

The File manager window will open displaying the job
file at the following directory: \CYPE Ingenieros\
Examples\CYPECAD, which will be opened later on
during the example.

Fig. 15.2

15.2.1. Data organising

15.2.1.1. Column layout drawing

A drawing of this type should be created, which should dis-
play:

• The start and end elevations of each vertical column ali-
gnment, shear wall and wall.

• Their respective sections with their pre-designed
heights.

• Angles

• Fixed points.

Please recall that the fixed point of a column is the corner,
mid-point or axis from which the transverse section can be
incremented. This point is defined so avoid the marked limi-
ting boundaries of the structure to be surpassed and so to
not invade openings. The user must know which column
faces cannot be moved.

15.2.1.2. Building elevation section drawing

This drawing should contain:

• Floor numbering

• Floor group assignment

• Surface dead and live loading

• Difference in height between top elevations of finished
consecutive floors

15.2.1.3. Floor table

Based on the previous drawing, the following table can be
created:
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15.2.1.4. Floor plans

It is convenient for the type of floor, depth, materials, parti-
tion loads, stair loads, local surcharges, joist layout direc-
tion, etc. to be known beforehand by the user to increase
the efficiency of the data introduction.

15.2.1.5. DXF or DWG template

Once the floor and column outlines, fixed point of the co-
lumns, etc. have been drawn, the building geometry can be
introduced much more quickly with the aid of a DXF or
DWG template in which these elements are already drawn.
Although other methods can be used.

Use of the DXF or DWG as a template is an advantage
compared to introducing the columns using coordinates or
other methods (relative dimensions, layout lines or out-
lines). It also proves to be useful for edge beams and stair
opening beams, patios, lifts, building services, etc.

If a DXF template is to be used, before exporting the file
from the CAD program, please ensure the number of deci-
mal places is set to 3.

Check the units of the drawing before importing it into the
program and ensure it is in the same units and order of
magnitude as the program.

15.2.2. Data introduction

15.2.2.1. Job creation

Follow this process to create the job:

• Click on File > New. In the window that opens intro-
duce the name of the job and click on Accept.

Fig. 15.3

• In the next window (New job window) the program will
ask the user to choose the introduction mode amongst
various options. Select Empty job (for this example)
and click on Accept.

Fig. 15.4

15.2.2.2. General data

Having accepted the previous windows, the General data
dialogue box will open. Here, a description of the job may
be introduced, the codes to follow selected, materials to be
used, horizontal loads to be applied, definition of load fac-
tors and additional loadcases, column effective length fac-
tors, edition of reinforcement tables and analysis options.
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Fig. 15.5

15.2.2.2.1. Code and materials

The concrete, rolled-steel, cold-formed steel, wood, ma-
sonry and composite slab codes can be selected, as well
as the type of concrete for each element of the job. The
type of steel to be used for the reinforcement bars can also
be defined.

For this example, the concrete to be used will be C25/30,
steel for bars S-500 and for the codes, select the corres-
ponding Eurocodes for each material by pressing on the
Codes button at the top of the dialogue box.

Using the By position button , the reinforcement tables
may be accessed and many analysis options can be edi-
ted and modified by the user.

In this example, columns will be designed in such a way
that all four faces will contain symmetrical reinforcement
and be continuous. Follow the steps to apply this arrange-
ment:

• Click on the By position button

• Click on the Vertical bar options button

Fig. 15.6

A new window will open.

Fig. 15.7

• Click on Symmetry criteria. Introduce 300 in the win-
dow that appears and Accept.

Fig. 15.8

• From the options window select Continuity criteria.
Select Apply from the next to last from the scroll
menu for the option The number of bars in the faces
must be greater than or equal to that of the higher
floor. Accept this option, Exit the Vertical bar options
window and the program will return to the General da-
ta window.
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Fig. 15.9

• To define the allowable bearing pressure of the soil,
click on the Foundation data button .

• In the emerging window, introduce an allowable bea-
ring pressure of 0.20 MPa for persistent situations and
0.30 MPa for accidental situations.

Fig. 15.10

15.2.2.2.2. Wind and earthquake loading

We recommend that a first analysis be launched with only
vertical forces applied so that a general adjustment of the
columns can be carried out. In the second analysis, the ho-
rizontal forces can be applied, if any, followed by the ad-
justment of all the resistant elements. In the case of an ex-
perienced user, predesign the columns so that only a sin-
gle analysis is required.

In this practical example, no horizontal loads will be intro-
duced.

15.2.2.2.3. Additional loadcases (special loads)

The use categories for the building are to be defined here.
Click on the Additional loadcases (special loads) button
and then on the use category icon. Select A.Domestic and
household and H. Roofs from the emerging window and
accept.

Fig. 15.11

The additional live loads of this example are introduced wi-
thout the need of having to define an additional loadcase.
Nonetheless, if other loadcases are to be created in ano-
ther job, be they compatible, incompatible or simultaneous
with other loadcases, click on the Additional loadcases
(special loads) button.

15.2.2.2.4. Limit states (combinations)

The limit states (combinations) can now be defined:

• Click on the Limit states (combinations) button in the
General data window.

• From the scrolling menus in the Limit states window
which appears, choose the Execution control, Use
category and Snow level for the job.
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• If special combinations are to be defined for a specific
material, click on the Configure combinations for
each limit state button at the bottom of the Limits
states window.

• In the new window, select the button corresponding to
the option whose limit states are to be modified.

Fig. 15.12

15.2.2.2.5. Effective length factors

Leave the default coefficients.

If the structure is analysed with vertical forces, a value of 1
for these parameters provides results with an applied sa-
fety factor. If there are horizontal loads acting on the struc-
ture, this value is also reliable as long as the analysis is
carried out taking into account second order effects.

15.2.2.3. Floor / Floor group definition

Floors and floor groups are defined as follows:

• Click on Introduction > Floors /Groups

• Click on New floors in the emerging window

Fig. 15.13

• Click on Single and click on Accept.

Fig. 15.14

• Introduce five floors and press the Enter key. Complete
the table and click on Accept.

Fig. 15.15

• The Floors and Groups window will appear again but
this time with more options.

Fig. 15.16



CYPECAD - Practical examples 13

CYPE

• Group the second and third floors. Select Join groups.
A new window will open to join the groups.

• Move the mouse cursor and click to select which floors
are to be grouped.

Fig. 15.17

• Click on Accept. From the dialogue box that appears,
either option can be selected as no floor geometry has
been defined yet (this option is intended for use if the
floors are grouped once their geometry has been defi-
ned and differs between the two floors. Upon grouping
them, since they both have to contain the same geo-
metry, the program prompts as to which geometry of
the floors is to remain).

Fig. 15.18

• Click on Accept and the Floors and groups dialogue
box will reappear.

• Click on Edit floors and introduce –0.90 as the value
for the Elevation of the foundation plane.

Fig. 15.19

• Click Edit groups and change the name of Floors 2
and 3 to 2nd and 3rd floors.

Fig. 15.20

15.2.2.4. Import DXF or DWG templates

As mentioned previously, the use of a DXF or DWG tem-
plate is very useful when introducing the geometry of the
structure. To import the DXF or DWG file:

• Select the Edit templates button from the toolbar.
The Template views manager window will open.
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Fig. 15.21

• Click on the Add icon and the Selection of templates
to read dialogue box will open asking for a DXF or
DWG file to be selected. Find the floor_geometry.dxf
file located in \CYPE Ingenieros\Examples \CYPE-
CAD\. Select and click on Open.

• Click on Accept to return to the Template views ma-
nager.

Fig. 15.22

• Click on Accept once again, to be able to view the tem-
plate on screen. Upon doing so the program will ask:
Would you like to assign the view to all the
groups? Choose Yes.

For this example, a template has been created (with a CAD
program) to be used for the floor geometry.

15.2.2.5. Column introduction

The columns will now be introduced.

• Click on Introduction > Columns, shear walls and
starts from the menu in the Column Definition tab.
The following dialogue box will open.

Fig. 15.23

• Click on New column. For the time being, all the co-
lumns will be introduced with the same dimensions
from the Foundations to the Lift machinery roof. The-
refore, accept the data that appears in the window.

Fig. 15.24

• Upon accepting, the dialogue box will close and return
to the main screen. Using the scroll wheel of the mouse
or by opening a zoom window using the icon in the tool-
bar at the top of the screen, zoom in, so to view the first
column in the DXF template.
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Fig. 15.25

• Click on the Template object snaps icon in the
toolbar at the top of the screen. The first column to be
introduced is a corner column, therefore the fixed point
of the column will be the bottom left hand corner of the
column.

• In the Object snap selection dialogue box that opens,
mark the Intersection box then click on Accept.

Fig. 15.26

• Place the mouse cursor over the bottom left hand cor-
ner of the column (its fixed point, marked on the tem-
plate with a red circle). Notice how a cross appears
when the mouse cursor is moved over two intersecting
lines.

Fig. 15.27

• Click on the bottom left hand corner. The corner of the
column has been snapped. However, the position of the
column that has been introduced does not coincide
with the column from the template.

Fig. 15.28

• To adjust the column, click on the right mouse button.
The New column window will open. Click on Cancel
and the Columns, shear walls and starts dialogue
box will appear.

Fig. 15.29

• Click on Edit followed by a click on the corner column.

In the Edit dialogue box, a diagram of the Fixed point
of the column is shown in the top right hand corner. The
possible fixed points of the column are displayed in
green, and the selected fixed point is displayed in red.
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Fig. 15.30

• Click on the bottom left hand corner fixed point to se-
lect it.

• Click on Accept.

• Click on the Full screen icon from the toolbar to obtain
a complete view of the floor.

Fig. 15.31

• Zoom to view the column situated to the right of the co-
lumn that has just been introduced. Click on the right
mouse button.

Click on New column in the Columns, shear walls
and starts window. The New column window will
open. Click on Accept.

• In this case the bottom right hand corner should be
snapped to and then carry out the corresponding ad-
justment in the Edit window.

Fig. 15.32

• Introduce the remaining columns always using the ob-
ject snap to snap to the fixed point, which is displayed
with a red circle in the template. When introducing a co-
lumn whose fixed point is at its centre, the adjustment
will not have to be carried out.

Fig. 15.33

Fig. 15.34

This process may be slow and tedious. However, there is
no need in carrying out a zoom on each column, a larger
zoom window can be used to view several columns, intro-
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duce them snapping to their fixed points and then adjust
each one. In this example, the process has been described
in detail so it may be understood well.

Another option is to introduce all the columns by snapping
to their centre in the DXF template and then use the Chan-
ge fixed point option, from the Columns, shear walls
and starts window. This option modifies the fixed point wi-
thout displacing the column.

When this tool is selected, the Fixed point dialogue box will
appear. Here the fixed point of the column can be chosen
and then assigned to the columns which are to have their
fixed point at that position.

Fig. 15.35

This way of introducing the columns may result to be more
comfortable, but remember that for the columns to be intro-
duced correctly, the dimensions must be the same as they
are in the DXF template. If this is not the case, the fixed
point will not be in its correct position. Therefore if a DXF
template is being used where the dimensions of the co-
lumns differ from one another, these must be changed
each time a new column is introduced or alternatively, once
they have all been introduced, edited one by one.

Now the start and end of the columns will be modified.

• Select Modify initial and final group from the Co-
lumns, shear wall and starts dialogue box.

• In the window that appears, deactivate the Initial
group box and for the Final group, select Roof.

Fig. 15.36

• Bearing in mind that the columns are number from left
to right and bottom to top, click on the Assign button
and click on the columns P1, P3, P5, P8, P9 and P10,
which will be marked in red. Click on the right mouse
button and select Finish.

• Click on Exit to close the Columns, shear walls and
starts window and to conclude the column introduc-
tion, click on the Beam Definition tab.

15.2.2.6. Introduction of group 1: 1st floor

Having clicked on the Beam Definition tab, the program will
situate the user on the first floor.

Firstly, activate the visibility of the element references.

Fig. 15.37
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15.2.2.6.1. Beams

• Click on Groups > Show references (or select
the icon from the toolbar at the top of the
screen). A window will appear where the Visible,
Columns, Beam dimensions/ reference boxes
are to be activated. The rest left unmarked.

Now the beams will be introduced.

• Click on Beams/Walls > Define beam. The Current
beam window will open.

• Select a flat beam by clicking on the top icon of the left
hand column.

• Click on the dimension representing the width of the
beam and change it to 0.30.

Fig. 15.38

• Click on Accept and the Define beam floating menu
will appear on screen.

Fig. 15.39

This menu contains general and specific help dialogue
boxes, which provide information on how to introduce
straight and curved, continuous or discontinuous, pro-
gram definitions, etc. To understand the introduction
modes of the program, it is highly recommended the
help dialogue boxes be consulted.

To change the dimensions of the beam to be introdu-
ced, click on the first button of the floating menu
and the Current beam window will reappear.

For this example, ensure the options of the floating menu
are set as follows:

o : Should be in Simple mode

o :Any of the three options can be activated depen-
ding on the user’s beam introduction preference.

o : The Without displacement option should be
activated.

o : Should have Straight option activated.

Whilst the floating menu is visible, beams are ready to be
introduced. If the menu disappears, it can always be activa-
ted by reselecting the Define beam option from the Be-
ams/Walls menu.

• Beams can be introduced and adjusted to their respec-
tive positions in the DXF template in two different ways.
One way consists in snapping the axes, faces or edges
of the previously introduced columns and then adjus-
ting the beam to the DXF template. The other way is by
snapping to the elements of the imported DXF tem-
plate, and so the beam is adjusted when it is being in-
troduced.

• Introduction of beam P1-P5 by snapping to co-
lumns.

o To snap to the axes, faces or edges of the columns,
the DXF or DWG object snaps must be deactivated.
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To do so, click on the icon in the toolbar and
deactivate any objects snaps which may be activa-
ted. Alternatively, pressing F3, wil l deacti-
vate/activate all the object snaps.

Fig. 15.40

o The third button of the Define beam floating menu
must be set to Centre. Click on column P1.

When the centre of the column has been selected,
the mouse curse will change to a red point.

o Click on column P5.

Fig. 15.41

o Having introduced this beam, its side has to adjus-
ted to the façade drawn on the template. To do so,
activate the Nearest object snap from the Object
snap selection window.

Fig. 15.42

o Select Beams/Walls > Adjust.
o Click on the left side of the beam

The beam is displaced automatically so that its side coin-
cides with the line drawn in the template.

Fig. 15.43

This adjustment, as well as displacing the beam so its side
face coincides with the template also establishes its fixed
side, which due to it being an edge beam at the façade of
the building is displaced 5 cm with respect to the face of
the column.

It is normal for the width of the beam to vary as the analysis
of the structure proceeds, and if a side of the beam is to be
maintained at a fixed position after it has been introduced, it
must be adjusted (to a template line, column face, etc.)

• Introduction of beam P1-P5 by snap to DXF tem-
plate

o Delete the beam P1-P5 (Beams/Walls > Delete)
to practise introducing the beam using a different
way.

o Select the option Beams/Walls > Define beam.

Note: The mouse cursor must be situated outside the width of
the beam but close to its left side, otherwise if it is placed within
the width of the beam, the axis of the beam will be adjusted to
the façade line.
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o Click on the button in the toolbar to activate the
Nearest object snap and deactivate any other ob-
ject snap which may be selected.

o The third button from the Define beam floating
menu should be set to Left adjustment. Posi-
tion the cursor at a point on the façade line of the
template between columns P1 and P5.

Fig. 15.44

o The symbol which appears when the cursor is
brought close to a line of the DXF template indi-
cates that if the user clicks on the left mouse button
at that point, the start of the beam will be at that
point. Introduce the initial and final points of the
beam by snapping to two points along the façade
line of the template, the first close to P1 and the se-
cond close to P5.

Fig. 15.45

o For the beam to span between column P1 and co-
lumn P5, it must be extended using the Extend be-
am command found in Beams/Walls > Extend
beam. The beam may also be introduced without
the need of having to extend it later on. If the initial
and final points of the beam are snapped to points

close enough to the columns, in such a way that the
width of the beam overlaps them, the beam
connecting columns P1 and P5 will be obtained.

Fig. 15.46

• To introduce a beam using any of the methods descri-
bed above, beam spans do not necessarily have to be
introduced from one column to the next column. Any
beam length can be introduced and the beam will re-
main joined to any column it overlaps.

Now introduce the remaining beams:

• Beam P5 - P8 (from column P5 to column P8). The op-
tion Beams/Walls > Extend beam can be used to ex-
tend the end of beam P1-P5 or introduce a new beam
using Beams/Walls > Define beam and then adjust it
to the template line using the option Beams/Walls >
Adjust, as was done with beam P1-P5. Each of the
spans introduced must be adjusted; in this case only
the second as the first was adjusted previously.

• Beam P8-P10, flat 0.40m width. External side adjusted
to the template line. In this case, the two ends of the
frame are introduced as column P9 is aligned with co-
lumns P8 and P10.

• Beam P4-P10, flat 0.30m width. External sides (right) of
both spans adjusted to the template line.

• Beam P1-P2, flat 0.30m width. External sides (bottom)
of the three spans adjusted to the template line.

• Beam P2-P3, dropped 0.20 × 0.40 m. External sides
(bottom) of the three spans adjusted to the template line.
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• Beam P3-P4, flat 0.40 m width. External sides (bottom)
of the three spans adjusted to the template line.

• Beam P5-P7, flat 0.50 m width. Not to be adjusted, the-
refore the program maintains the longitudinal axis fixed
in case its width varies.

Fig. 15.47

The beam that has just been introduced contains a span,
P6-P7, which partly defines the stair opening, but its side
does not coincide exactly with the opening.

What must be done in the job (the user should correct and
reflect it in the drawing) is to infill the area between the side
of the beam up to the edge of the opening.

It does not make sense to move, in this case, the beam so
that its side coincides with the stair opening (as it would
have to be moved a large distance), and therefore, the axis
of the beam would not lie within the width of the columns.

• Beam P2-P6, flat 0.30 m width. External side (right) adjus-
ted to the template line which defines the stair opening.

• Beam P3-(P6-P7), flat 0.25m width. The beam spans
from P3 and ends perpendicular to beam (P6-P7). The
Orthogonal on/off option can be used from the tool-
bar or roughly introduce the second end of the beam
and then adjust to the template line.

• 0.25 m width flat beam closing off the bottom of the lift
opening. Similar to the previous case, it is introduced at
its approximate position, then adjusted.

• 0.25 m width flat beam which closes off the right hand
side of the lift opening. Similar to the previous case, it is
introduced at its approximate position, then adjusted.

• Click on the Edit templates icon from the toolbar. In
the window that opens, deactivate the Visible box from
the top table.

The floor layout should be as follows:

Fig. 15.48

It can be seen that beams introduced as flat beams do not
have depth. They will automatically adopt the depth of the
panel they hold.

If two panels reach the same beam, the beam will adopt
the greatest depth of the two.

As there are important section variations in the same beam
alignment, it is convenient that the reinforcement be divided
at these section changes.

• Click on Beams/Walls> Beam alignments > Divide
an alignment.

• Place the cursor over P2. A red dot and a scissor sym-
bol will appear. Click on the column with the red mouse
button.

• Repeat over P3.

Fig. 15.49
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15.2.2.6.2. Floor slabs

Follow these instructions to introduce the floor slabs:

• Click on Slabs > Panel manager. A floating menu will
appear. Initially and whilst no slabs are introduced,
nearly all the icons in this window will appear deactiva-
ted. This window contains most of the tools required to
manage slab introduction.

Fig. 15.50

• Click on the first icon from the floating menu . The
Panel manager dialogue box will appear.

Fig. 15.51

• Select the Joist floor slabs option. The dialogue
box will change to display the options associated
with joist floor slabs (these will vary depending on
the selected construction codes).

Fig. 15.52

The types of joist floor slabs available can be selected
by clicking on their respective image. By clicking on the

icon and then on the image, the name of the type
of joist slab is displayed. To be able to select some of
these types, the user must have acquired the corres-
ponding modules. The selected default option is that of
a concrete joist floor slab to be used to introduced ge-
neric precast joist slabs. This corresponds to the first
image. Click on it if it is not already selected.

• The properties of the slab that is going to be introduced
have to be defined. To do so, click on the button which
lies below the joist images. A new dialogue box opens
where the corresponding data has to be introduced.

Fig. 15.53

• Having done so, click on Accept and the program will
return to the Panel manager window. In the bottom
part of the screen, the layout of the joists is defined. For
this example, select the first option: Parallel to a beam
and accept the dialogue box.

• The slab can now be introduced. Click on the opening
defined by columns P1-P2-P5-P6.

• The direction of the joists has to be defined. Click on
beam P1-P5. The slab as been introduced.
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The remaining slabs can be copied from the one that has
just been introduced. This is recommended so that joists
from adjacent slabs have a continuous layout.

• To do so click on the Copy panel icon from the
floating menu. Click on the slab that has just been intro-
duced. A new window will open from which the data to
copy can be selected. Accept the window with the pro-
posed selection.

Fig. 15.54

Now click on the openings to introduce the slabs displayed
in the following figure.

Fig. 15.55

• To introduce an opening where a slab has been introdu-
ced, select Delete panel from the floating menu,
then click on the slab to be eliminated.

15.2.2.6.3. Loads

There are two general methods to introduce loads. The first
is to introduce the loads manually using the options in the
Loads window (Loads >Loads). The second is available
for line and surface load introduction which consists of an
automatic introduction of loads on beams in the case of
line loads (Loads > Line loads on beams) and on slabs
in the case of surface loads (Loads > Surface loads on
slabs). The latter option is the quicker option and is useful
only if the loads are to be assigned to the entire element. In
the case of loads partially assigned to the element, the user
will have to judge whether to introduce the loads manually
or automatically and then edit them to obtain the real distri-
bution.

Follow this process to introduce the line loads:

• Click on Loads > Line loads on beams

• First introduce the dead loads. In the window that
opens, type in a load of 7.00 kN/m. Select Dead load
for the Loadcase.

Fig. 15.56

• Click on Add and the window will close so the load can
be introduced.

• Assign the load to all the perimeter beams.
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Fig. 15.57

• Click on the right mouse button and select Finish from
the window that appears.

• Click on Loads >Loads.

• In the new window, select Line load, type in
12.00 kN/m, leave the Loadcase as Dead load and
select New. This will correspond to the self weight of
the staircase on both supports:

Fig. 15.58

Fig. 15.59

• Complete the remaining loads.

• To introduce the live loads transmitted by the staircase,
select the Live load in the Loadcase compartment from
the Loads window.

• Introduce the two 6.00 kN/m line loads on the stair sup-
ports.

Fig. 15.60

Fig. 15.61

The floor introduction has been completed. The second
floor can now be defined:

• Click on the Up a group arrow in the toolbar.

• It may occur that, if the described beam and slab intro-
duction order has not been followed exactly, upon going
up to a different group, the program may ask for the
depth of the beam separating the stair and lift openings.

In this case, if the beam remains divided in two spans, it
has been defined as flat but does not have a slab on ei-
ther side of it.

This is of no great importance. Introduce, in this case,
the same depth as has been defined for the slab. This
way, it remains a flat beam.
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15.2.2.7. Introduction of group 2: 2nd and 3rd floors

As this group is very similar to the previous group, it may
be copied and then edited to carry out the necessary
changes.

• Click on Groups > Copy
from another group. In
the window that opens,
place the mouse cursor
over the first group. The
text corresponding to the
Selected group at the
top of the screen will dis-
play 1. 1st floor. Click on
that floor or press Accept.

Fig. 15.62

• Activate the template by carrying out the opposite pro-
cess to that explained earlier to deactivate it. Deacti-
vate the visibility of the loads by pressing Loads >
Shown.

Fig. 15.63

15.2.2.7.1. Beams

Beams P1-P5-P8 and P8-P9-P10 are not to be adjusted to
the template line as they are in the group below, as they do
not coincide with the façades. They must be adjusted to
the column axes. To do so:

• Deactivate all the template object snaps (in the toolbar).

• Select Beams/Walls > Adjust followed by a click on
the longitudinal axis of the beam at the centre of its
span. This will adjust its axis with the axis of the co-
lumns on which it is supported.

If the cursor is not placed at the middle of the span, i.e.
the cursor is close to one of the beam ends, only that
end will be adjusted. However, the same can be done
at the other end.

• Repeat this process at each of the aforementioned
spans.

It must be noted that adjustment to columns (be it to their
face or axis) can only be done if the template object snaps
have been previously deactivated.

The following beams will now be introduced. When the
connection of several beams does not occur at a column,
introduce beam segments shorter than their real length.
These beam spans can be adjusted to the DXF template
lines whilst they are being introduced or first introduced and
then adjusted later. Their ends are then extended and fi-
nally the unwanted ends can be cut off.

An example of what has been described can be seen in the
introduction of the beams parallel to the west and north fa-
çades. These beams define the two overhanging slabs of
this floor group. To introduce them, follow the instructions
described below:

• Activate the Nearest object snap from the toolbar.
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• To introduce the beam parallel to the west façade, se-
lect a flat beam width 0.25 m. To do so, click on the first
button of the floating menu Current beam selec-
tion. If this window is not visible, activate it using the
Define beam option from the Beams/Walls menu.

• Select the Left adjustment by clicking on the button
of theDefine beamwindow. This buttonmay differ depen-
ding on the current adjustment at the time: or .

• Introduce the first point of this beam by bringing the
cursor near to the DXF template line to be snapped to
until the snap symbol appears on the DXF template
line as is displayed in the image.

Fig. 15.64

• Once the object snap has appeared, click on the left
mouse button. If the mouse is then moved, the begin-
ning of a beam can be seen anchored on its left side to
the point that has just been snapped to.

Fig. 15.65

• Now the final point of the beam fragment that is being
defined has to be defined. This can be done by ap-
proximating the cursor to the DXF template line where
the object snap symbol will appear, followed by a click
with the left mouse button at that moment. The beam
will have the following appearance:

Fig. 15.66

• Introduce a beam segment parallel to the north façade,
following the same procedure as in the previous exam-
ple. In this case use a 0.10 m wide non-structural beam
with a width of 0.10 m.

Fig. 15.67
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• The non-structural beam must be introduced as shown
in the following figure.

Fig. 15.68

• Extend the two beams (further than is required) using
the option Beams/Walls > Extend beam.

Fig. 15.69

• Delete the unnecessary beam segments using the op-
tion Beams/Walls > Delete.

Fig. 15.70

• Extend and delete beam segments until the following
layout is obtained.

Fig. 15.71

15.2.2.7.2. Floor slabs

Introduce the floor slabs by copying those that have al-
ready been introduced. This way the joists are continuous
as was explained earlier.

15.2.2.7.3. Loads

The perimeter line loads of the north and west façades
change position.

• Use the option Loads > Loads > Move to obtain the
following layout.
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Fig. 15.72

• Click on the Up a group icon in the toolbar to proceed
to the next group.

15.2.2.8. Introduction of group 3: Roof

The roof layout is very similar to the previous group.

• Copy the group below. The line loads must be modified.

• The external line load values are changed from 7.00 kN/m
to 4.00 kN/m corresponding to the roof wall. This can be
done using the option Loads > Loads > Edit.

• The roof wall has a brief interruption when it reaches
the wall of the lift machinery room. The loads must be
moved. Do so using the option: Loads > Loads >
Move.

• The load to introduce due to the wall of the Lift machi-
nery room is 6.00 kN/m.

The loads transmitted by the staircase can be reduced as
the stair only reaches the floor. The start loads of the stair
can be deleted.

The loads around the perimeter of the lift opening are in-
creased to 8.00 kN/m. These correspond to the machinery
slab where it is supported and the walls that support the
slab. This slab must be designed in a separate file. The
load distribution should look as follows:

Fig. 15.73

• Click on the Up a group icon in the toolbar.

15.2.2.9. Introduction of group 4: Lift machinery roof

Introduce the geometry of the Lift machinery roof, which is
shown in the diagram below. There are no line loads.

Fig. 15.74

15.2.2.10. Introduction of group 0: Foundations

15.2.2.10.1. Pad footings

The foundations of the building will consist of pad footings.

• Click on the Go to group icon in the toolbar and in the
window that opens select Foundations. The first ele-
ments to introduce will be the pad footings followed by
the strap and tie beams.

• Select Foundation > Foundation elements. The fol-
lowing floating window will appear:
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Fig. 15.75

• Whilst no pad footings have been introduced, the floa-
ting menu only displays the first option as being availa-
ble. This window contains helps which inform the user
on the tools provided to introduce footings and pile
caps.

• Click on the first icon and the following dialogue
box will appear:

Fig. 15.76

• Select the Single column elements option and the
first of the three buttons which represents a reinforced
concrete footing. The other two buttons are used to in-
troduce mass concrete footings and pile caps.

• Click on Accept. Introduce a corner footing at P1. To
do so, bring the mouse cursor close to the column and
move it around the column. It can be observed that the
cursor changes indicating what type of footing would
be introduced if the user were to click at that moment.

This way, if the cursor is placed in the top right hand
corner, the symbol which is displayed represents a foo-
ting with the column situated in the bottom left hand
corner.

Fig. 15.77

• Click and the footing will be introduced.

Fig. 15.78

• To introduce an edge footing at column P2, place the
cursor in the following way. This way the edge footing is
obtained.

Fig. 15.79

Fig. 15.80

• To introduce a centred footing at column P6, the cursor
must be placed directly over the column. The cursor will
display two concentric squares. Click to introduce the
footing.
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Fig. 15.81

• Now a combined pad footing will be introduced at co-
lumns P3-P4. To do so, click on the right mouse button
and in the window that opens select Multiple column
elements.

Fig. 15.82

• Click on Accept. Select, by means of a capture win-
dow, columns P3 and P4 or by clicking on one and
then the other. The selected columns should be dis-
played in yellow.

Fig. 15.83

• Now click on the right mouse button. A cross and circle
will appear, indicating the insertion point of the footing.
Move the cursor of the mouse until the cursor symbol
changes to that of a corner footing.

• Click and the footing will be introduced.

Fig. 15.84

• Introduce the remaining footings until the layout has the
following appearance:

Fig. 15.85

15.2.2.10.2. Strap and tie beams

Fig. 15.86

Having introduced the footings, the strap and tie beams are
to be introduced. This order is followed so that once the
pad footings have been introduced (corner, edge, centred,
etc. footings) the program will automatically balance the
beam only at the end at which there is an eccentric column
on the footing (eccentric in the direction of the beam).

• Click on Foundation > Strap and tie beams.

The strap and tie beam floating menu will appear.

Only the first icon will be activated, the rest will be acti-
vated once a beam has been introduced. This window
provides help and information on all the tools used in
the introduction of strap and tie beams.

• Click on the first icon in the floating menu . A dia-
logue box will open.

• When the new window opens, the selected default op-
tion is that of the automatic balancing beam. Leave this
option as the selected beam.
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Nothing has to be selected. The scroll menus display
the selection of beams the program contains in its ta-
bles. CYPECAD selects the optimum sections of the
beams parting from the smallest that exist in the table.

• Therefore, click on Accept.

• Introduce the first beam between P1 and P5. It can be
seen that the balancing symbol only appears at the bot-
tom end of the beam, which is the only position where
the balancing action is required. Now introduce the re-
maining beams as shown.

Fig. 15.87

Fig. 15.88

15.2.3. Analysis

Now that all the data has been introduced, the structure
can be analysed. If the data has not been completely intro-
duced as has been instructed up to this point, this example
is available at \CYPE Ingenieros\Examples\CYPECAD.

• Click on Analyse > Analyse the job (except founda-
tion).

The reason why the foundation should not be analysed,
for the time being, is due to the reason that, usually, co-
lumns, beams, etc require section modifications after
the first analysis, and therefore a new analysis of the
structure must be launched to account for any load
changes.

The foundation of the structure can be designed, as will
be seen later on, having completed the rest of the struc-
ture.

Once the analysis has concluded, a report appears on
screen informing the user of any errors that have ari-
sen.

• To check the results, click on the Results tab.

15.2.4. Results revision
15.2.4.1. Columns

It is recommended that the columns be the first elements to
check.

15.2.4.1.1. Displacements (only with horizontal loads)

Even though horizontal loads have not been used in this
job, it is necessary for the analysis to be carried out consi-
dering second order effects (the coefficient that multiplies
the displacements will be left the assigned value of 1).

When the analysis has ended, it should be checked that
the global stability coefficient is greater than 1.20. If so, the



32 CYPECAD

CYPE

stiffness of the structure must be increased in that direc-
tion, as it is easily deformed and has little stability in that di-
rection. If the value is less than 1.1, its effect is negligible.

15.2.4.1.2. Force check

The user may consult axial forces, moments, shear and tor-
sion forces by loadcase at any column elevation, analyti-
cally and graphically.

The worst case forces can also be consulted (loadcase
combinations which result in having to provide maximum
reinforcement) for any span.

Click on Envelopes > Forces in columns and shear
walls. Click on a column, for example P6.

Fig. 15.89

It is recommended that, if not all, at least some of the co-
lumns of the structure are checked.

The axial force at the start of the column provided by the
program must be approximately equal to that calculated by
hand. The variance is due to the difference in the estimated
tributary area due to the hiperstaticity of the structure in ge-
neral and especially of the slabs.

It must be taken into account that the forces provided by
the program belong to simple loadcases and, therefore,
they do not have an applied safety factor and are indepen-
dent for dead loads, live loads, etc.

15.2.4.1.3. Section check

• Select the option Columns > Edit, followed by a click
on the first column. The Column edition window will
appear.

Fig. 15.90

In the bottom left hand corner of the window, the Plan
view of the columns can be seen. Here, the columns
sharing the same reinforcement (i.e. which belong to
the same column group) are highlighted with a circle;
one of them in a bold circle. In this case, P1 is in the
bold circle. This means P1 is the master column of the
group, hence any modifications carried out on P1 will
also be carried out on the other columns of the.
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Fig. 15.91

At the end of the column information line of a floor, a
tick or cross appears indicating the column span is
adequate or it fails, respectively.

A more detailed report of the checks carried out on the
column can be found in the Summary of code
checks section on the bottom right hand corner of the
Column edition window. If there are any errors, the co-
lumn section has to be redesigned.

Upon modifying the column section in this window, the
reinforcement redesign of the columns will be carried
out using the simple loadcase combinations belonging
to the last analysis.

If the section modifications are important, or if they are
of little importance but horizontal wind and/or seismic
loading is present, the structure must be reanalysed
with the new sections as their inertia will have varied.

• Run through all the columns by selecting them in the
Column group section in the top left hand corner of the
Column edition window, up to column P10, and check
that they do not contain any errors.

If horizontal loads are present, it is recommended the
section of the columns be increased when reinforce-
ment bars with a diameter greater than 16mm appear.
This way, it will avoid, after the second analysis, 25mm
reinforcement bars being used.

15.2.4.2. Beams

15.2.4.2.1. Force check

It is convenient to check at least the bending moment enve-
lopes of all the beams of the structure in a graphical way.

• Go to group 1. Deactivate the visibility of the joist top
reinforcement by clicking on Joists > Views and deac-
tivating the Top reinforcement box.

Fig. 15.92

• Click on Envelopes > Forces in beams. In the win-
dow that opens, activate the negative and positive mo-
ment boxes.
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Fig. 15.93

• Click on a beam.

Fig. 15.94

• The remaining beams should be consulted on all floors.
If the diagram of an envelope is not coherent, it is
convenient that this span be checked and to ensure
that the sum of half of the moments at its ends plus the
whole of the centre moment approximately correspond
to the simply supported moment.

Bear in mind that these envelopes have an applied sa-
fety factor and, as was said previously in the case of
forces in columns, the tributary area considered by the
user when carrying out manual calculations is only an
approximation to what occurs in reality, due to the hi-
perstaticity of the slab. The user must also be aware
that the simply supported moment W L2 /8 is for line
loads but what the joists really transmit to the beam is a
series of point loads.

15.2.4.2.2. Section check

Beams containing an error with their reinforcement, deflec-
tion, etc. or that stand out for a reason will be displayed in
red.

• To know the reason of the error or warning click on Be-
ams/Walls > Beam errors, followed by a click on the
beam displayed in red. In our example, one of these
beams is P9-P10 in Group 2.

Fig. 15.95

This beam has a deflection problem. In this case, as
only this problem is present, the reinforcement of the
beam can be edited and increased, or increase the
width of the beam. Here, the second solution will be ap-
plied.
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• Select the Beam Definition tab. Click on Beams/Walls
> Assign beams.

Fig. 15.96

• Select Based on beam adjustment and click on Cu-
rrent beam. In the new window that opens select a flat
beam with a width of 0.5 m.

• All three beam spans making up the frame must be
clicked on.

Fig. 15.97

• As section changes have occurred, the beams must be
redesigned. Click on Analyse > Redesign frames
with changes. Upon doing so, a warning message will
appear which should be read carefully.

• Click on Yes. Select the Results tab and check the new
deflection of the beam.

• Repeat this process with the same span in Group 3,
only with a width of 0.55 m.

15.2.4.3. Joist floor slabs

15.2.4.3.1. Force check

It is convenient for some joist bending moment envelopes
to be checked.

• Return to Group 1. Click on Envelopes > Forces in
joists. In the window that opens only activate the posi-
tive and negative moment boxes.

• Click on a joist.

Fig. 15.98

• The user should continue checking the remaining joists
on all floors and, if the diagram of an envelope is not
coherent, it is convenient the same check be carried out
as with the beams.

15.2.4.3.2. Section check

Joists containing errors such as shear, deflection, etc. or
that stand out for a reason will be displayed in red.

• To know the reason for the error or warning click on
Joists > Errors, followed by a click on a joist in red.
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Fig. 15.99

The deflection of this joist and others adjacent to it over-
come the deflection limits. The are various solutions to de-
flection problems. In this case a double joist will be placed
where the joists only have one span. To do so, follow the
following steps:

• Select the Beam Definition tab. Open Slabs > Panel
manager. In the window that opens select Enter dou-
ble joist.

• The previous window will close and the joists are to be
entered from right to left sequentially on the joists of the
top right slab.

Fig. 15.100

• Reanalyse the structure. Click on the Results tab. Se-
lect Joists > Information.

• Click on the joists which had deflection problems. The
problem has now been solved.

Fig. 15.101

15.2.4.4. Foundation

15.2.4.4.1. Design

First of all the foundation has to be analysed, if it has not
been already. But, as a previous step, the pad footings will
be assigned a minimum depth of 1m. To do so:

• Go to group 0 (foundation).

• Click on Job > General data.

• Click on the By position button.

• Click on the Foundation tab.

• Click on the Strip and pad footing options.

• Click on the Pad footing options.

• In the window that opens, introduce a value of 100 in
the Minimum depth box.
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Fig. 15.102

• Close all the windows until the following option can be
activated.

• Click on Foundation > Design.

• The following window will open. Activate the same op-
tions that have been activated here (please observe
that the Iterative design option has been selected).

Fig. 15.103

15.2.4.4.2. Errors check

• Click on Foundation > Code check errors. Elements
that do not contain any design errors will be displayed
in black. Those containing errors in red. In any case, by
clicking on any elements drawn in red, a message will
be displayed containing the checks that have been car-
ried out and any design or check errors, if any.

• Click on, for example, the footing below P6.

Fig. 15.104

15.2.4.4.3. Footing overlaps

Overlapping does not occur in this example however, it is
useful to know that if it does arise, an option is available to
create a combined footing by selecting the route Founda-
tion > Eliminate overlaps. They can also be joined ma-
nually (Join option in the Foundation elements dialogue
box) if the distance between them is less than 50 cm.

15.2.4.4.4. Results check

Follow the steps to obtain quick information on the data en-
tered and results of the footings:

• Click on Foundation > Foundation elements > In-
formation. A window will appear with options of what
information to show.
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• Click on the footing below P6.

Fig. 15.105

15.2.5. Reinforcement modifications

Having checked the forces, sections, etc., the reinforce-
ment can be edited.

15.2.5.1. Columns

The column reinforcement can now be matched.

• Select the Results tab.

• Click on Columns > Edit. Click on a column. Click on
the icon in the bottom left hand corner of the Co-
lumn edition window.

• In the emerging window, P1 is marked with a bold cir-
cle, which indicates it is the selected column of the
group. Columns P3-P8-P9-P10 are also marked with
circles to indicate they belong to the same group as
the selected column. If column P5 is selected, for
example, it will be marked with a bold circle, to indicate
it is the selected column.

Fig. 15.106

• Click on P4. It will be displayed in a bold circle (be-
cause it is the selected column), P2 can be seen dis-
played in a circle. This indicates that P2 belongs to the
same group as P4 because they have the same geo-
metry and have obtained the same reinforcement after
the analysis. They have been grouped by CYPECAD so
they may appear as a single entry in the column sche-
dule in the drawings.

Fig. 15.107

Column sections and reinforcement can be copied from
one group to another. Click on Groups > Copy geo-
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metry and reinforcement to other groups (in the top
left hand corner of the Column edition window). The
Group selection window appears. In this case, the cur-
sor was situated on the P2 and P4 row in the main win-
dow, hence the grouping possibilities of this group are
displayed i.e. columns P6 and P7.

Fig. 15.108

Columns P6 and P7 are displayed in yellow on the floor
layout plan and listed in the column on the left. Mark the
boxes in the column and close the window. P2 and P4
are now grouped with P6 and P7.

The program now displays these two newly added co-
lumns in red and red crosses appear in the Reinforce-
ment edition section. This is because they fail with
their newly assigned reinforcement. Click on the Rede-
sign reinforcement in the top right hand corner of the
Column edition window and the program will provide
the required reinforcement for the new group.

Manual modifications can also be carried out. If any
modifications cause the column span to fail, a cross will
appear at the end of the span in the Reinforcement
edition section and in the Column group section. The
columns will also be displayed in red in the Plan view
of the columns section and their corresponding Sum-
mary of code checks is highlighted in red.

Fig. 15.109

• Press Finish to conclude.

15.2.5.2. Beams

• Go to group 3. It can be seen that beam P9-P10 has a
deflection error that can be solved by slightly increasing
its reinforcement.

• Click on Beams/Walls > Edit beams, followed by a
click on the aforementioned beam. The Beam reinforce-
ment editor window will open.

Fig. 15.110
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• Click on the deflection icon and place the mouse
cursor over beam P9-P10. Its current deflection is dis-
played; in this case the active and long term deflection
fail (displayed in red).

• Click on the Longitudinal reinforcement icon fol-
lowed by the Edit icon .

This operation will be used to modify the longitudinal
reinforcement.

• Click on the diameter symbol of the top reinforcement
of beam P9-P10 and change the diameter of the top
and bottom bars to 20 cm.

Fig. 15.111

• Click on the Resituate icon for the program to
check the new reinforcement.

• Check the deflection of the beam to ensure it lies within
the limit.

Fig. 15.112

As can be seen, by consulting the beam reinforcement of
the beam, it can be modified without having to change the
section of the beam to solve errors that arise in the design,
for example with deflection problems if it is not excessive.

If the beam only fails due to deflection, the top or bottom
reinforcement can be modified until the error is solved.

The deflection is automatically recalculated upon indicating
the new reinforcement.

15.2.5.3. Joist floor slabs

It is convenient that moments (or reinforcement) be mat-
ched, as the analysis provides individual bottom reinforce-
ment for each joist.

• Go to Group 1. Click on Joists > Bottom reinf. >
Match. A new window will open with the percentage dif-
ference for the match and the criteria to be taken for the
match; whether it should take the maximum or average
value.
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In the case, the Average value will be selected and the
percentage set at 50%. This is because joists passing
by columns, upon the stiffness of the support being
greater, the amount of top reinforcement increases
greatly and the bottom reinforcement is equally redu-
ced.

Fig. 15.113

That is what really occurs, however construction criteria
is of greater importance that the theoretical analysis va-
lues.

• Click on Accept and the match will be carried out.

Fig. 15.114

• Now match the reinforcement on the remaining floors.
All that has been said for the bottom reinforcement is
applicable to the top reinforcement.

• Activate the visibility of the top reinforcement: Joists >
Views.

• Click on Joists > Top reinf. > Match. A window will
open displaying the percentage difference for the

match. In this case, only the lengths will be matched
(25% difference), therefore different steel areas will not
be matched. The lengths will be matched using the
average value criteria.

Fig. 15.115

• Click on Accept and the match will be carried out.

Bars shown in magenta are those that have been mat-
ched with others and will not be displayed in the dra-
wings.

Fig. 15.116

• To deactivate the visibility of the hidden bars click on
Joists > Views and deactivate the Show hidden box.
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Fig. 15.117

If the match that has been carried out is not sufficient,
another option can be used which allows to copy the
reinforcement of other joists by following the steps indi-
cated below:

• Click on Joists > Top reinf. > Modify.

• Select the reinforcement to modify. A window will ap-
pear with a description of the reinforcement.

Fig. 15.118

• Click on the Copy button.

• Click on the reinforcement to copy. The Modify reinfor-
cement window will open and display the reinforcement
of the selected bar(s).

Fig. 15.119

• Click on Accept.

• Once all the necessary modifications have been carried
out, click on Joists > Top reinf. > Match.

• Continue matching the reinforcement on the remaining
floors.

Fig. 15.120

The top reinforcement of the joists can also be matched by
matching the steel areas and lengths of the bars. To do so,
in the Match top reinforcement window that appears, select
the Match steel areas option.
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Fig. 15.121

A more uniform result is obtained by using this matching
method. In some occasions, the negative moment of a joist
that coincides with a column is substantially different to the
other joists of the same panel. By matching the steel areas,
the negative moment difference is shared amongst the
joists adjacent to the joist that coincides with the column (it
is logical for the joist to behave like this in reality), and so
the difference with the remaining beams of the slab is not
so large. This, occasionally, implies that all the top reinfor-
cement of a slab must be matched with the same reinfor-
cement or that, at least, the difference between the top
reinforcement of the joists belonging to the same slab will
be smaller.

15.2.5.4. Foundation

• Place the view of the screen at group 0

• When there are small differences in the size of the pad
footings (rounded to multiples of 25cm), it is convenient
to group them. This is done using the option Founda-
tion > Foundation elements > Match.

No matching will be carried out in this exercise as there no
footings of the same type. Nonetheless, the size of the foo-
tings can be increased so that their total dimensions are
multiples of 25 cm. This can be done in two different ways:

First option:

• Click on Foundation > Foundation elements > Edit.

• Click on the footing below P6. The following window will
open.

Fig. 15.122

• Click on Geometry. The dimensions of the footing will
appear.

• Change the dimensions to what is shown in the follo-
wing figure.

Fig. 15.123

• Now, to redesign the reinforcement, click on Design >
Redesign.
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Fig. 15.124

Having done so, continue modifying the remaining pad
footings.

Second option:

This option has the advantage that it is carried out on all
the pad footing simultaneously.

• Click on Job > General data.

• Select the By position button.

• Click on the Foundation tab.

• Click on the Strip and pad footing options button.

• Select the Pad footing options button.

• In the window that opens introduce a value of 25 in the
Width increment box.

• Redesign the foundation (activating the iterative de-
sign option).

It is also recommended that the strap (and tie beams, if
there are any present) be matched. For the time being,
there is not an option that carries out an automatic match,
and so, it must be done manually. For example, to match

all the beams with the same section, but different reinforce-
ment:

• Make a note of the strap footing with the greatest rein-
forcement for the same depth. In this example for type
VC.T-4, the VC.T-4.2 and VC.T-4 are available. The first
beam will be used as it has a greater stirrup reinforce-
ment area.

• Select Foundation> Strap and tie beams > Edit be-
am design.

• Click on a VC.T-4 beam, for example the one joining P6
and P9. The Strap beam edition window will appear.

Fig 15.125

• Click on the Selection button.

Fig. 15.126
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• In the new window, a scroll down menu appears where
a different strap beam may be selected amongst those
available from the table. In this case, select the VC.T-
4.2 beam.

Repeat his process on all the necessary beams.

15.2.6. Application of finishing touches to texts be-
fore obtaining drawings

To avoid texts overlapping in the drawings, their positions
may be modified. Texts overlapping reinforcement must
also be avoided, etc. Therefore, all the reinforcement
should be activated as visible beforehand. The following
steps should then be taken:

• Click on Groups > References and right click.

• The Column, joint and frame references window will
appear.

The Modify position option allows for any texts that
are visible to be changed. But first, the visibility of these
references must be activated.

Fig. 15.127

• Click on the Show references button and activate all
the boxes (Click on the Mark all button).

• Accept all the windows.

• Click on and move each of the overlapped texts or any
that are to be moved.

Fig. 15.128

Fig. 15.129

As a final comment, the position of the texts can also be
modified when the drawings are obtained.



46 CYPECAD

CYPE

15.2.7. Drawings

The next step consists in creating the job drawings.

The formats of the drawings do not have to be configured
previously; the program carries this out automatically ba-
sed on the format configuration defined in the Control Pa-
nel of the system, to which the program also adds the DXF
and DWG configuration.

However, as there are various drawing sizes for DXF and
DWG files (in this example the drawings to be obtained will
be DWG files), the first thing to do is select a specific dra-
wing size.

To do so:

• Access the following option: Click on the Configura-
tion icon > Drawings

• In the window that opens select the A0-A4 format. This
is the format created by the program to obtain DXF and
DWG files.

• In the Sizes column, click on A0. Having done so, the
size should appear marked in red in the window on the
right, where all the sizes defined for the format are
drawn.

Fig. 15.130

• Close this window by clicking on Accept.

Now the drawings will be obtained. Follow the steps indica-
ted below:

• Click on File > Print > Job drawings.

• In the Drawing selection window that opens, add a new
element to the list. The Drawing editor window will
open.

• Activate Floor plans from the Drawing type menu.

• Select for the drawings to be drawn from floors 1 to 4.

• Click on Accept.

Fig. 15.131

The program will return to the Drawing selection window.
The selected drawing will be displayed in the table.

• Select DWG in the Peripherals column.

Fig. 15.132
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In this case, the beam drawings should be drawn together
with the floor plans. To do so:

• Add another element to the list in the Drawing selec-
tion window.

• Activate Beam drawings from the Drawing type
menu.

• Select for the drawings to be drawn from floors 1 to 4.

Fig. 15.133

A construction detail is to be added to this drawing.

• Activate the Details button. The Details window will
open.

Fig. 15.134

• Add a new element to the list; the Detail selection win-
dow will open, which contains the construction details
included in the program.

• Activate the EHU tab.

• Select detail EHU399.

Fig. 15.135

• Click on Accept consecutively until the Drawing se-
lection window is displayed.

• Choose DWG from the Peripherals menu.

A title block for the drawings is to be selected. In this case,
the CYPE title block will be chosen.

• Click on the Title block button.

• From the Title block selection window that opens, ac-
tivate CYPE.

• Click on Accept.

Fig. 15.136
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Fig. 15.137

The program returns to the Drawing selection window. A
preliminary view of the drawings can now be seen.

• Click on Accept. The Fields editor window will appear
where the data to be displayed in the title block can be
entered.

Fig. 15.138

• Click on Accept.

The Drawing composition window will open, which offers
a preliminary view of the drawings to be generated and al-
lows for certain actions to be carried out, such as: change
the scale, move the position of the image within the dra-
wing, change text positions, etc.

Each floor, frame, etc. drawing is initially displayed as an
object lacking in details, that is, a drawing where only its
border is shown. This allows for the object to be redrawn
more quickly if modified than if it were entirely displayed.

Fig. 15.139

• To view the real image of the drawing, click on Objects
> Drawing detail and select the objects to be seen.

Fig. 15.140
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• To change the position of the texts, select Objects >
Edit object and click on an object. The Drawing editor
window will open, in which a text can be moved by
clicking on it and then at its new position.

Fig. 15.141

To finally print the drawings:

• Click on Drawings > Print > Print all.

• The Filenames window will appear, where the file-
names and directory can be specified.

• Click on Accept.

Fig. 15.142

15.3. Example 2
The following example is to be used as a guide for the cor-
rect introduction of a building, consisting of nine apart-
ments, with its ground floor to be used for business pur-

poses (a shop or similar) and basement. Each project has
its individual properties and generally cannot be extrapola-
ted to other projects. However, in this example, solutions
will be proposed to specific properties which can later be
applied to future projects.

Fig. 15.143

15.3.1. Initial data

The project should be studied before it is introduced so to
avoid errors and hence not waste any time having to re-
peat entering and redefining data.

Fig. 15.144
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First and foremost is to identify how many groups (levels)
there are in the building. This example will contain 6:
ground floor, first, second and third floor, roof and lift ma-
chinery roof. As floors 2 and 3 are the same, geometrically
speaking, and their loading is also, these two floors can be
grouped, resulting in a building of 5 groups and 6 floors.

15.3.1.1. Floor heights

When there is an elevation change in a floor, as occurs in
this example where there is an area on the ground floor
42 cm higher than the rest of the floor, depending on the
elevation difference and surface area of the floor slab, there
are different ways as to how it can be defined in the pro-
gram.

If the elevation difference is small (<0.65 m) or the surface
of the higher area is not too large, the user may opt to infill
the area, without altering the height of the floor slab. In this
case, the only thing that must be done is apply a surface

load to the slab equivalent to the increase in dead loading
corresponding to the infill. This is the case in this example,
and so a load will be introduced to represent the infill.

If the elevation difference or surface area is large, an eleva-
tion change should be assigned to the floor slab using the
option Groups > Sloped floor slabs/El. Changes. This
way, the program creates a floor slab with two elevations
and if these are separated by a flat beam, the beam will
change to acquire the depth of the slab plus the elevation
change between the two slabs. If the elevation difference is
greater and the user does not wish for there to be a
connection between the two parts, an intermediate group
will have to be created between the current and the follo-
wing floor. In this case, the height of the intermediate floor
will be the elevation change between the two floor areas.

15.3.1.2. Loads

15.3.1.2.1. Permanent loads

First the permanent loads acting in the example will be ana-
lysed so to then introduce them when defining the project in
the program. Note that the slab loads, once the slabs to be
introduced have been defined, will be applied internally by
the program. Therefore, the user does not have to define
them when introducing the dead loads to be applied.

NB: It must be taken into account that if there is going to be a
start or end of a structural element (column, wall, stair nucleus or
sloped beam), it cannot occur at a grouped floor; it must be de-
fined as an individual floor.
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15.3.1.2.2. Live loads

The live loads acting on the floor slabs will depending on
what they will eventually be used for. For this example, the
following loads have been taken:

15.3.1.2.3. Wind loading

For the wind loading, the generic code will be used. Here,
the shape factors of the building will have to be established
as well as the tributary widths.

15.3.1.2.4. Earthquake loading

The modal spectral analysis will be used to apply the seis-
mic loads to the building. An acceleration of 0.10 g will be
assumed.

15.3.1.2.5. Snow load

A snow load of 0.2 kN/m2 will be taken for the analysis.

15.3.1.2.6. Fire resistance

The basement floor will have to verify a fire resistance of
120 min and the remaining floors a resistance of 60 min.

15.3.2. Job creation

Click on File > New. A dialogue box will appear where the
name and description of the new project are to be defined.

Fig. 15.145

Upon accepting, a new dialogue box will open where the
user can choose to enter the structure in four different ways
(the remaining two options are examples).

Fig. 15.146

• Empty job. If an IFC or DWG/DXF file of the project or
is not available, the Empty job option should be selec-
ted.

• Job import from Metal 3D. If the project that is going
to be created is based on one whose structure has pre-
viously been created in Metal 3D, then the option Job
import from Metal 3D should be selected. This way,
the program will ask for the Metal 3D job to be selected
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which will then create a job in CYPECAD with the codes
and loadcases that were defined when the steel struc-
ture was defined.

• Automatic introduction option. If DXF/DWG files of
the project are available, the project can be introduced
using the Automatic introduction DXF/DWG option.

• Finally, if the IFC file of the job is available, the work car-
ried out previously in the CAD program can be made
the most of to introduce the project using the Automa-
tic introduction IFC option.

The job will be introduced using two methods (15.3.2.1.
Automatic introduction DXF/DWG or 15.3.2.2. Automa-
tic introduction IFC) so to view the differences. Having
concluded, the introduction will continue at point 15.3.3.
Column introduction (Column Definition tab).

15.3.2.1. Automatic introduction DXF/DWG

Fig. 15.147

Select the option and accept. A new dialogue box appears
where the data of the building is to be defined.

15.3.2.1.1. Assistant: Building data

The Basements box will remain activated with a 1 introdu-
ced in the adjacent box indicating there is one basement. It
is to have a height of 2.50 m and no live load or dead load
as the structure is going to have pad footings.

The Ground floor is to have a height of 3.80 m with a live
load of 5 kN/m2 and a dead load of 2.1 kN/m2 (partitions +
screed). For the Floors, the box is to remain activated, intro-
ducing a 3 in the adjacent box to indicate there are three
floors. They are to be assigned a height of 2.8m, a live load
of 2 kN/m2 and a dead load of 2.1 kN/m2.

The Roof is also to have a height of 2.8 m with an applied
live load of 1.2 kN/m2 (live load + snow load) and a dead
load of 1.5 kN/m2 (roof screed).

Finally, the Lift machinery slab box is to remain unactivated.
The Lift machinery roof box is to be activated and is alloca-
ted a height of 3.5 m. Its loading will be the same as that of
the Roof.

Before accepting and moving on to the next window, the
Columns have been introduced with external fixity box
will remain activated as the foundations of the building will
consist of pad footings which require for the columns to be
introduced with external fixity.

Fig. 15.148
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15.3.2.1.2. Assistant: Floors/Groups

Floors 2 and 3 are the same and therefore belong to the
same group. This is to be indicated in this window. To do
so, deactivate the box in the Group start column corres-
ponding to that of Floor 3. A bracket will appear in the dia-
gram on the right indicating that Floors 2 and 3 are now a
group. The Elevation of the foundation plane is to be left
at –2.5 m.

Fig. 15.149

15.3.2.3.1.3. Assistant: Group description

Data that has previously been introduced can be edited in
this window as well as renaming the groups to be genera-
ted if necessary. In this example, the default data shall be
accepted.

Fig. 15.150

15.3.2.3.1.4. Assistant: DXF/DWG template

The CAD files are saved in the directory: \Cype Ingenie-
ros\examples\CYPECAD. To upload them, click on the
icon which opens a dialogue box from which the DXF/DWG
template can be selected. Go to the above directory, select
all the files and click on Open.

Fig. 15.151

Once the files have been imported, their layers can be acti-
vated and modified. In this case, the layers shall be left as
they are; only when the background on which the work is
being carried out is white is it convenient to change the
layer colours to darker tones. By clicking on the Colour co-
lumn header, the colour of all the layers can be changed at
once to the same colour.

15.3.2.3.1.5. Assistant: Views

In this example, a different CAD file has been used for each
group therefore nothing has to be done in the views win-
dow. If only one drawing file is imported, a different view
must be created for each group defining the corresponding
layer configuration.

Nonetheless, if there are layers present in any of the files
which are not going to be of any use for the introduction,
these may be deactivated so to avoid any unnecessary
confusion.
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Fig. 15.152

15.3.2.3.1.6. Assistant: Assign views to groups

In this window, each group will be assigned a view or CAD
file. If the name of the file coincides with that of the group, it
will be assigned automatically, otherwise a group must be
selected from the list on the left and activate the box of the
corresponding view or file to be assigned from the list on
the right. The process is to be repeated for each of the floor
groups of the project.

Fig. 15.153

15.3.2.3.1.7. Assistant: Column layers

The columns have been drawn in the same layer for all the
groups and so the first of the two options at the top is to be
marked. The layer in which the columns have been drawn
(Columns) is to be selected from the table and, as the
fixed point of the columns has been drawn in the CAD file,
the Layers defining the fixed point box should be activa-
ted and then the corresponding Fixed point layer selected.

Fig. 15.154

15.3.2.3.1.8. Assistant: Beam layers

The same is to be done for the beams. First the layer cor-
responding to the exterior perimeter of the floors is selec-
ted. Once this has been done, the beams are assigned a
width of 30 cm and due to the drawing template being that
of the finished floor, a 5 cm displacement towards the in-
side is to be applied.

For the openings, select the following layers: Lift opening,
stair opening and car lift opening. As in the case of the
beams, these are assigned a width of 30 cm but without an
applied displacement. Finally, select the Building services
openings layer and assign it a non structural 15cm wide
beam.
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Fig. 15.155

Click on Finish to conclude the automatic introduction. To
continue with the example, proceed to point 15.3.3. Co-
lumn introduction (Column Definition tab).

15.3.2.2. Automatic introduction IFC

15.3.2.2.1. IFC Assistant: IFC file selection

Using the Automatic introduction using an IFC file, a dia-
logue box opens where the IFC file has to be selected. In
this case select the file: Project.ifc.

Fig. 15.156

Once the file has been imported, a view of the file is dis-
played. Below it, a description of any errors that have been
incurred during its import.

Fig. 15.157

15.3.2.2.2. IFC Assistant: Floor heights

By clicking on the Next button, the Floor heights window
opens where the floor structure with which the IFC file has
been created can be seen. Below the diagram, the eleva-
tion of the foundation plane can be modified. In this case
introduce an elevation of –2.5 m. Due to the type of founda-
tion to be used (pad footings), the Fixed (without external
fixity) option is be selected.

Fig. 15.158
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15.3.2.2.3. IFC Assistant: Floor loads

Here, the live and dead loads will be introduced. The Base-
ment does not have any loading as the structure’s founda-
tion elements will consist of pad footings.

The ground floor is to have a live load of 5 kN/m2 and a
dead load of 2.1 kN/m2 (partitions + screed). The residen-
tial floors are to have a live load of 2 kN/m2 and a dead
load of 2.1 kN/m2. Finally, the roof and lift machinery roof
are to have an applied live load of 1.2 kN/m2 (live load +
snow load) and a dead load of 1.5 kN/m2 (roof screed).

Fig. 15.159

15.3.2.2.4. IFC Assistant: Columns

Having defined the floor loads, the columns are now to be
defined. The assistant displays the different materials with
which the columns have been defined; in this case only
one. The columns made of the same material as that dis-
played in the list are drawn in red.

Fig. 15.160

15.3.2.3.2.5. IFC Assistant: Floor slabs

Now that the column materials to be imported have been se-
lected, the floor slab materials are to be selected as well as
their perimeter beams and the beams defining the openings.

The assistant displays a similar list to that of the columns,
with the floors/floor slabs defined in the IFC file. Upon
clicking on one of these, it is displayed in red in the 3Dview.
Those that are not to be imported are deactivated in the
Import column (Floor: road, Floor: pavement, Floor: Gene-
ric 100, Floor: Generic 200 mm).

Fig. 15.161
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Once these have been deactivated, click on Floor: Waffle
slab. To the right, in External Outlines, select the flat beam
(first on the left), assign a thickness of 30 cm to it and for
Openings select the limit beam (first on the right) with 0 cm
thickness.

Repeat the process for Floor: Generic 300.

15.3.2.2.6. IFC Assistant: Partition loads

Now that the floor slabs have been defined, the partitions
to be imported are selected. These are assigned a material
which has an associated surface load. The program will
then calculate the corresponding line load to apply on the
floor slab depending on the height of the partition.

In a similar way as with slabs, upon clicking on a partition
from the list, it will appear marked in red. To assign the ma-
terial, click on the Not defined button to select the type. In
the example a generic material has been used with a load
of 2.86 kN/m2.

Fig. 15.162

All the materials corresponding to partitions will be deacti-
vated in the Import column.

Fig. 15.163

15.3.2.2.7. IFC Assistant: Drawing templates

Lastly, the elements which are to appear in the DXF/DWG
template generated by the program based on the imported
IFC file will be selected.

Fig. 15.164
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15.3.3. Column introduction (Column Definition tab)

15.3.3.1. Job general data

15.3.3.1.1.Code and materials

Once a name has been given to the project, the General
data window appears. The codes to use, materials and
loads to be applied in the job are to be specified in this
dialogue box.
For this example the Eurocodes will be used. By clicking on
the Codes button, a new dialogue box will appear where
the codes to be used for each material can be selected:

Fig. 15.165

The type of concrete to be used is C25/30, steel for bars S-
500 and for cold-formed, rolled and welded S 275.

Fig. 15.166

15.3.3.1.2. Wind

In the Loads section of the dialogue box, activate the With
wind loading box. The Generic code is to be used. In the
new window that opens, introduce the tributary widths of
the building. Click on the By floor button and introduce a Y
value of 23 m and an X value of 17m for groups 1 to 5 and
Y = 4 m and X = 7 m for group 6. Change shape factor x
to 1 and shape factor y to 1.35. Leave the gust factor and
wind action values as they appear in the program.

Fig. 15.167

Fig. 15.168
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15.3.3.1.3. Earthquake loads

The seismic loading can be activated by selecting theWith
seismic loading box in the General data dialogue box.
From the window that opens, select the Modal spectral
analysis option on the left. The corresponding screen will
appear on the right where the data can be defined.

For this example, an acceleration due to gravity of 0.10 g
will be used. The ductility shall be left at 2.50 and the part
of snow and live loads to consider will be left at 0.5.

As for the number of modes, the number to be selected
must be such that the whole mass of the structure is displa-
ced. 3 modes of vibration can be considered for each inde-
pendent zone, i.e. for this example 18 vibration modes
should be considered (6 floors with 3 vibration modes each).
Bear in mind that the higher the number of modes is consi-
dered, the longer the analysis will take as this number af-
fects the number of combinations the program undertakes
when designing the reinforcement. Therefore it is preferable,
for the initial analysis whereby what is sought is to obtain a
rough idea as to the eventual dimensions of the elements,
that the 6 default modes be left. Once the first analysis has
concluded, the report containing the participation coeffi-
cients may be consulted and if the percentage of the displa-
ced mass is greater than 95%, then the number of modes
considered is adequate, otherwise it must be increased.

To select the spectrum, click on the Library manager button
and select Import predefined data . From the list

that appears, mark the box corresponding to EUROCODE
8 Type:II Subsoil:A.

Fig. 15.169

Fig. 15.170

15.3.3.1.4. Fire resistance

To carry out the fire resistance checks and the structural
design with the correct fire resistance, select the Check fire
resistance box. A window will open where R120 must be
activated for the Ground floor and R60 must be activated
for the remaining floors. Floors with compartmentation
function must also be activated.

Fig. 15.171

Accept all the dialogue boxes that appear (one of which
may include a report displaying introduction errors and war-
nings) until the floor layout can be seen on screen.
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15.3.3.2. Creation of project floors and groups

15.3.3.2.1. Group floors

If the job has been imported using an IFC file, any floors
that are to be grouped should be specified. As was mentio-
ned in section 15.3.1., floors 2 and 3 are to be defined as a
single group. To do so, go to option Introduction >
Groups > Join groups in the Column definition tab. In
the window that opens, a diagram of the floors is displayed
with a red bracket indicating which floors are to be joined.
Select floors 2 and 3.

Fig. 15.172

Having selected the floor and accepted the window, a dia-
logue box will appear asking from which floor the informa-
tion for beams and loads is to be kept. As both are the
same, any can be selected.

Fig. 15.173

15.3.3.3. Column introduction

Columns may be introduced manually or via automatic in-
troduction. In this second example, the structure has been
introduced automatically. Please refer to the first example
for a more detailed explanation as to how to introduce the
columns manually.

After importing the job using one of the two automatic as-
sistants, the columns must be reorganised so that their re-
ferences follow an order which allows for an easy consulta-
tion. This is especially important for large jobs where having
to locate a column without these following a specific order
can be very complicated.

To edit the references, click on Introduction > Columns,
shear walls and column starts > Modify reference.
Click on the bottom left hand column; this will be the first re-
ference. In the dialogue box that appears, provide a refe-
rence for this column and select the Number consecuti-
vely box. Then, one by one, click on the columns in order,
from left to right and bottom to top.

Fig 15.174
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Fig. 15.175

15.3.4. Introduction of beams, walls and floor slabs
(Beam Definition tab)

15.3.4.1. Walls

Situate the main view of the screen on the Ground floor to
introduce the basement wall. If the previous data introduc-
tion has been carried out using the Automatic introduction
option or by IFC file import, the beams marking the perime-
ter of the building must first be deleted: Beams/Walls >
Delete and click on the beams to eliminate.

So that no overlapping problems arise when introducing
the wall, the beams perpendicular to it will also be deleted.
If any beams have been introduced in the Basement, these
too must be deleted.

Fig. 15.176

Now the wall can be introduced. (Trick: the entire beam
does not necessarily have to be deleted; using the option
Beams/Walls > Define beam, introduce a beam seg-
ment perpendicular to the internal beam that is to be dele-
ted at roughly its mid-point. Delete the half that would be in
contact with the wall and the beam segment. Later on,
once the wall has been introduced, all that has to be done
is extend the beam (Beams/Walls > Extend beam). This
way the original position of the beam is not lost.)

To introduce the wall go to Beams/Walls > Define wall. A
dialogue box displaying four options will appear:

• Reinforced concrete wall

• Normabloc wall

• Reinforced concrete block wall

• Masonry walls

Fig. 15.177

The first wall type is to be selected (reinforced concrete
wall). In the emerging window, indicate the wall begins at
group 0 and reaches group 1. It will be assigned a thick-
ness of 0.15 m to the left and right.
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Now to define the pressures acting on the
wall due to the soil: Click on the Lateral
pressures button. The Wall Pressure
edition dialogue box will appear. Click on
the Edit soil pressure button.

Fig. 15.179

The Infill situation dialogue box will open. The pressures
will be defined as dead loads with no additional loadcases.
Click on the Soil button so to define it.

Fig. 15.180

In the Soil edition dialogue box, mark theWith fill box. In-
dicate it is to reach an elevation of 0m, and leave the remai-
ning parameters as they are. In the Loads section, a uni-

form load of 10 kN/m2 is to be defined: click on the
icon. A default load will appear in the table. If required, this
can be edited using the icon and clicking on it.

Fig. 15.181

Having accepted the Earth pressures on walls dialogue
box, the Wall pressure edition window will emerge in
which the direction of action of the pressure has to be defi-
ned. The wall is going to be introduced in an anticlockwise
sense and so, theWith pressures acting to the right box
should be marked. Accept the window.

Fig. 15.182

Fig. 15.178
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Finally, before introducing the wall, the foundations must
be defined. In this case theWith external fixity box will be
marked and click on the Edit foundation button to es-
tablish the type of footing. The Foundations. With exter-
nal fixity window will open. Here, mark the Strip footing
and Overhang only on the left options. The depth and
overhang dimensions are to be left as they are. Accept the
dialogue box.

Fig. 15.183

The defined wall can now be introduced. Click on P1 and
move the cursor to P3 (There is no need to click on P2 first
due to columns P1, P2 and P3 being aligned. Finish off the
introduction of the wall with a click on P3.

Fig. 15.184

Click on P3 to start the new wall span and then on P4 to fi-
nish it off. As there is an irregular intersection between co-
lumns P4 and P8, the wall will not be introduced and will be
dealt with later on. Continue introducing the rest of the wall:
P8-P19, P19-P17 and P17-P1.

The wall must now be adjusted. Click on Beams/Walls >
Adjust. Once the option has been selected , press the F3
button on the keyboard (or the magnet icon on the toolbar

which will activate the Object snap selection window.
Mark the Activate object snaps (F3) and the Nearest
boxes and Accept.

Fig. 15.185

Place the mouse cursor on the side of the wall which is to
be adjusted and close to the CAD template. The nearest
symbol will appear. At that moment click with the left mouse
button and the wall will be adjusted to the template. Repeat
this process with all the walls.
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Fig. 15.186

Fig. 15.187

Click on Beams/Walls> Extend wall. Click on the end of
the wall reaching P4 and extend it by dragging it past the
intersection. Click to end the extension. Now click on the
end of the wall reaching P8 and drag until a red dot is dis-
played at the point where it intersects with the wall that has
just been extended. Click with the left mouse button to
confirm that is where the wall is to end.

Fig. 15.188

Now, using the option Beams/Walls > Delete > Delete
the selected wall segment in all the groups to delete
the unwanted wall segment past the intersection.

Fig. 15.189
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Fig. 15.190

Now that the wall has been completed, a question mark
appears indicating there is a closed precinct in which a
floor slab is awaiting definition.

Fig. 15.191

Remember to deactivate the object snap settings by pres-
sing on F3.

15.3.4.2. Beams

If the job has been introduced using Automatic introduc-
tion DXF/DWG go to the following section 15.3.4.2.1. Alter-
natively, if the Automatic introduction IFC has been used,
go to section 15.3.4.2.2.

15.3.4.2.1. Data introduction using Automatic introduc-
tion DXF/DWG

The beams that were previously deleted to introduce the
wall will now be re-introduced. Zoom into the car lift area.
Using the option Beams/Walls > Extend beam (select
the Beam that is extended option and leave the Fixed
length box unmarked), extend the beam reaching P6 so it
connects with the wall. When it reaches the intersection with
the wall, a red dot will appear. When this occurs, click with
the left mouse button to confirm the point.

Fig. 15.192
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Fig. 15.193

Now to introduce the beam spanning from P6 to the wall at
the bottom of the screen. First of all, the beam closing off
the stairs opening must be deleted otherwise it will overlap
with the beam to be introduced as it lies in its path. (Trick:
Instead of completely deleting it, it is best to extend it to the
right, delete the segment on the left and then introduce the
beam. This way, a segment of the beam will remain adjus-
ted to the outline and can then be extended). Now the
beam spanning from P6 can be introduced.

Click on Beams/Walls > Define beam. Select the Cu-
rrent beam icon (first on the left) from the floating menu.
The Current beam dialogue box will appear. Select a drop-
ped beam (second option) with a width of 20 cm and depth
of 35 cm. Accept the dialogue box and click on P6 and
then at its other end at the wall. Adjust it to the CAD tem-
plate by activating the object snaps and clicking on Be-
ams/Walls > Adjust.

Fig. 15.194

Fig. 15.195
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Fig. 15.196

Extend the small beam closing off the stairs opening and
delete the unwanted segment on the right. Finish off by in-
troducing the limit beams that were deleted defining the
basement ventilation opening.

Fig. 15.197

Now the beams of the Lift machinery roof will be defined.
Click on the Go to group icon in the toolbar. In
the Go to group window that appears, click on Group 5:
Lift machinery roof.

Fig. 15.198

Using the option Beams/Walls > Assign beams the
width of the vertical beam reaching P10 will be modified. In
the Assign beams dialogue box, select the Based on be-
am adjustment option and click on the Current beam
button. Edit the beam in the Current Beam window so that
it is a flat beam with a width of 50 cm. Click on the Accept
button and then on the Assign button in the following win-
dow. Bring the cursor close to the beam in question and it
will be displayed in yellow. Click with the left mouse button
and it will modify the beam. Modify the small beam seg-
ment on the other side of P10 in the same way. Right click
with the mouse button to end the command.
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Fig. 15.199

Having modified the beam, its end shall be extended to
P14 using the option Beams/Walls > Extend beam (lea-
ving the default option Beam that is extended activated).

Fig. 15.200

Finally, using the option Beams/Walls > Define beam, in-
troduce a flat 50 cm wide beam from columns P11 to P15.

Fig. 15.201

Once all these beams have been introduced, the user can
proceed to introduce the floor slabs (explained in point
15.3.4.3)

15.3.4.2.2. Data introduction using Automatic introduc-
tion IFC

The beam introduction process for this option is the same
as that indicated above in point 15.3.4.2.1. in the case of
Automatic introduction DXF/DWG, only here a previous
step must be taken before carrying out the process.

When the IFC file was imported, the beams to be generated
were to be limit beams. Therefore using the option Be-
ams/Walls > Assign beams, the beams must first be mo-
dified to what they should be in each case.
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15.3.4.3. Floor slab introduction

Using the Go to group icon in the toolbar si-
tuate the main view of the screen on the Ground floor. Go
to Slabs > Panel manager and from the floating menu
select Define panel .

In the Panel manager dialogue box that opens, selectWaf-
fle slab. A window will open offering the user to choose
amongst predefined waffle slabs with lost forms. Click on
Cancel. A second window will appear offering waffle slabs
with removable forms. Click on Cancel. Two empty rectan-
gles should be visible on the right of the Panel manager
dialogue box.

For the Type of form, select Lost. Click on the Add new
element to the list icon . In the new window that opens
type the name of the new slab: Waf. 30+5 rib 12 spacing
82 and Accept. In the new dialogue box, the properties of
the slab have to be defined.

Fig 15.202

First it has to be assigned a reference. Label it 30+5. The
type of form has to be defined: its material and layout. In
this case the form will be made out of concrete and will
contain three elements. The geometric data will be the

same in both directions, the total depth 35 cm, compres-
sion layer thickness 5 cm, 12 cm ribs, and a rib spacing of
82 cm.

The program will automatically calculate the concrete vo-
lume and weight of the slab depending on the parameters
introduced. However, these values can be modified by mar-
king the Concrete volume and Dead load boxes and in-
troducing the new values.

Fig. 15.203

For the Rib layout direction, leave the Parallel to a beam
option selected. Accept the window.

Fig. 15.204
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If the cursor is brought over an opening, it will be highligh-
ted in yellow. By clicking in the opening and then on a
beam to which the ribs are to be parallel, the slab will be in-
troduced.

Fig. 15.205

Fig. 15.206

Now that the floor slabs have been introduced, the drop
panels can be generated using the option Slabs > Drop

panels > Generate drop panels. When this order is exe-
cuted, drop panels are generated at each column with di-
mensions equal to 16% of the distance between columns
that lie within the angle of vision (40º) with a maximum of 5
times and a minimum of 2.5 times their depth. These maxi-
mum and minimum values can be configured in the menu:
Slabs > Drop panels > Configuration of drop panel
generation.

Fig. 15.207

Now to assign a top base reinforcement of 12 mm bars in
both directions. Go to Slabs > Assign base reinforce-
ment and click on the waffle slab. From the right hand co-
lumn in the Waffle slab assembly window that opens, select
1ø12 and press the arrow buttons to assign it as top longi-
tudinal and transverse reinforcement. Click on Assign all
then on Finish.

Fig. 15.208
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Finally, to define the openings, click on Slabs > Panel
manager and from the toolbar click on the Delete panel
icon and click on the three openings which display a
question mark.

The Ground floor elements have been defined. Go up to
the next group where a new slab will be defined and intro-
duced: Waf. 25+5 rib 12 spacing 82. It has the same pro-
perties as the previous slab only, in this case, the total
height is 30 cm.

Fig. 15.209

It is important when defining the floor slabs that the posi-
tions of the ribs coincide on plan. This way, when down-
pipes are positioned on a floor, we can be sure it will not
come across any other ribs on other floors. Therefore, it is
best to copy the slab distribution from one floor to another.

In this case use the following option to copy the relevant
properties from the Ground floor: Slabs > Panel mana-
ger and from the floating menu select Copy panel. Right
click with the mouse button and the Go to group window
will appear. Click on the Ground floor and when it appears
on screen click on the waffle slab. A dialogue box will open
asking which properties are to be copied. Select the Inser-
tion point, Direction and Base reinforcement. The pro-
gram will return to the original floor group where the proper-
ties can be copied onto the slab by clicking on it.

Fig. 15.210

Fig. 15.211

Finally, generate the drop panels for the group: Slabs >
Drop panels > Generate drop panels.
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Fig. 15.212

Go up to the next group and repeat the same process only
this time select all the properties to copy from the group
below. Repeat the process for the remaining groups.

Fig. 15.213

15.3.4.4. Finishing touches

Now that the beams, slabs and drop panels have been in-
troduced, the necessary finishing touches can be applied
so to have a more adequate structural behaviour. For this
example, the following guidelines should be considered:

• All overhanging beams will be extended at least their
overhanging length towards the inside.

• Any main beams defining openings will have their ends
extended to the closest support band.

• Secondary opening beams will have their ends exten-
ded a little after their intersection.

Starting off at group 1: Ground floor. The car lift and stairs
area is separated by a beam which reaches P6. This beam
is to be extended to the edge of the drop panel. The beam
parallel to it on the other side is to be considered a main
beam. Therefore it is to be extended to the wall at one end
and the other to the edge of the drop panel. All this is to be
done using the option: Beams/Walls > Extend beam,
leaving the option Beam that is extended activated.

Fig. 15.214
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To complete the finishing touches of the group, the stair
beams are to be extended 65 cm from the axis of the stair
beams. To do so, click on Beams/Walls > Extend beam
and in the dialogue box select Beam that is to be exten-
ded, mark the Fixed length box and type in 0.65. Click on
Accept and click on the two ends to be extended. Right
click to end.

Fig. 15.215

Now to group 2: 1st Floor. The first beam to modify is the
beam supported by P10. The beam is to have its top end
extended to the top of the drop panel, past P14 and simi-
larly with the bottom end.

Fig. 15.216

The beam parallel to the previous beam will also be exten-
ded: its top end to the next rib after the imaginary line
connecting P14 and P15, and the bottom end to the next rib.

The beam to defining the right side of the lift opening is
also to be extended. The ends will be taken to the edges of
drop panels of columns P11 and P15.

Fig. 15.217

NB: The position of the drop panels after being generated de-
pends on the position of the ribs of the waffle slabs. Problems
may arise if the edge of a drop panel is overlapped when exten-
ding a beam; the program may warn of an incorrect introduc-
tion.To solve this problem, temporarily move the edge of the
drop panel using the option Slabs > Drop panels > Move
corners. Having moved the edge, extend the beam past the ori-
ginal position of the drop panel edge, then move the edge back
to its position. It may occur that due to there being a small area
between the original edge and the extended beam that it is best
to completely extend the drop panel into the beam. The beam
segment lying outside the drop panel can now be deleted.
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Using the option Slabs > Drop panels > Move corners,
move the top right hand corner of the drop panel of co-
lumn P11 so that it lies above the beam intersection.

Fig. 15.218

The next step is to edit the bottom beam of the lift opening
and change it to a 15 cm wide non-structural beam using
the option: Beams/Walls > Assign beams > Current
beam and selecting the non-structural beam and leaving
the Based on beam adjustment box marked.

Fig. 15.219

The beam defining the bottom of the stairs opening will now
be extended to the right until it reaches the vertical beam to
the right of the lift opening.

Fig. 15.220

The top beam of the lift opening will also be extended to the
left until it reaches the vertical beam defining the right side
of the lift pit.

Fig 15.221



CYPECAD - Practical examples 75

CYPE

Finally, the secondary beams reaching the main beams will
be extended 85 cm using the Fixed length command within
the Extend beam option.

Fig. 15.222

Repeat the entire process with the remaining groups.

15.3.4.5. Load introduction

15.3.4.5.1. Surface loads

The surface loads due to the infill on the ground floor and
the access stair to the machinery room on the Roof have
to be introduced. Using the Go to group option, situate
the screen on the Ground floor. Apply the option Loads >
Loads , select surface load and assign a value of
6.72kN/m2 (0.42 m of infill at 16 kN/m3), leave it as a dead
load. Click on the New button and introduce the load by
clicking on the vertices of the perimeter of the infill area, fi-
nishing off the introduction by clicking on the right mouse
button.

Fig. 15.223

By following the same steps, introduce the surface load in
the area of the ramp applying a load corresponding to its
average height: 3.36 kN/m2 (0.5×0.42 m · 16 kN/m3). This
concludes the surface load introduction on the Ground floor.

Fig. 15.224
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Moving on to the Roof, the surface load due to the machi-
nery room will now be applied. In a similar way as to what
was done in the Ground floor, a load corresponding to
49 cm of infill (average height of the stair) i.e. 7.84 kN/m2

(0.49 m · 16 kN/m3) will be introduced.

Fig. 15.225

15.3.4.5.2. Line loads

Line loads are to be introduced corresponding to partitions
or walls that due to their importance cannot be addressed
as general partitions whose load is included in the applied
loads of the building.

The introduction process will commence at the Ground
floor. Click on Loads> Line loads on beams and insert a
value of 11 kN/m, leaving the loadcase with the Dead load
option. Select New and click on the beams defining the
perimeter of the floor, i.e. beams on which an external wall
will be supported. Click on Loads>Loads and select a line
load of 11 kN/m to introduce the loads surrounding the
stairwell and ramp.

Fig. 15.226

Having introduced the line loads on this floor, move up to
the next floor and introduce, in a similar manner, the line
loads corresponding to the external walls (8 kN/m) and
guardrails of the balconies (3 kN/m).

Fig. 15.227
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Fig. 15.228

The same loads will be introduced in group 3.

The loads to apply in group 4; Roof, will be as follows:
3 kN/m due to the guardrail around the perimeter of the buil-
ding, 8 kN/m for the external walls of the lift machinery roof.

Fig. 15.229

Fig. 15.230

The load transmitted by the machinery room of the lift to the
Roof will have to be introduced. This load corresponds to
the self weight of the slab 5 kN/m2 and a load due to the
machinery of 10 kN/m2. Due to the supported width of the
slab being 0.9 m for the left support, 1.28 for the central
support and 0.38 for the right support, the following loads
must be introduced respectively: 13.5 kN/m, 19.2 kN/m and
5.7 kN/m.

Fig. 15.231
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Fig. 15.232

15.3.4.5.3. Load views

For an easier load consultation and introduction, the pro-
gram has an option to configure the loads which are to be
visible.

The view selection can be done depending on their type
(point, line or surface) and so allowing to view all the loads
of that type belonging to various loadcases or by selecting
the specific loadcase to consult.

Fig. 15.233

15.3.4.6. Stairs

The first stair to define will be the one providing access to
the Basement. This stair consists of a single 1.1 m wide
span, spanning across a height difference of 2.50 m by
means of 14 steps with an individual height of 17.86 cm.

Position the screen at the Basement and select the follo-
wing option Job > Stairs. A floating menu will open. Click
on the New staircase option and a window will ap-
pear to introduce the parameters of the staircase.

The emerging window contains two tabs. Within the Stair-
case data tab, enter a reference and introduce the data of
the staircase: width 1.1 m, tread 0.28 m, riser 0.1786 m and
select any of the two rotation options as it will have no effect
on the staircase due to it being a single span. The steps are
to be built using bricks and as there are no handrails,
change the value to 0 kN/m. The floor load is to be assi-
gned a value of 1 kN/m2 with an applied live load of
3 kN/m2.

Fig. 15.234

Once the basic data of the staircase has been defined,
click on the Spans tab to define the geometry of the span.
Click on to introduce the new span. In the emerging
window, introduce a reference number, indicate there is
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only one consecutive flight and add a new type by pressing
on the icon.

Fig. 15.235

The new staircase will be assigned the reference name Base-
ment. Activate the box Initial steps built on floor and select,
from the options that appear, Straight with 4 steps. Having
accepted the dialogue box, select the Straight flight from
the Predefined shapes and indicate it is to have 10 steps.

Fig. 15.236

Upon accepting all the windows, the program will return to
the floor view where the stair is visible next to the cursor
(horizontal). To place it in its correct position, the object
snap tools will be used to snap to the CAD template. Click
on to open the object snap selection window and select
the intersection and centre object snaps. Bring the cursor
close to the start of the stair and click, using the left mouse
button, when the centre of the circle is snapped to. Move
the cursor towards the end of the flight and click when the
intersection symbol appears. The flight has been introdu-
ced. To exit the ‘enter stair command’, right click with the
mouse button and click on Cancel.

Fig. 15.237

Now the staircase allowing access to the residential area of
the building will be defined. The staircase consists of a
flight on the ground floor, spanning a height of 3.8 m and 3
identical flights corresponding to the residential floors, each
with a height of 2.8 m.

Firstly, situate the main view of the screen at the Ground
floor (group 1) and click on the New staircase option. Give
the staircase a reference and introduce the data of the
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staircase: 1m width, 0.28 m tread and 0.175 m riser. Select
the rotation of the staircase to be to the Left and mark the
option: The intermediate landing or landing form the last
step. The steps are to be built using bricks and the han-
drail, floor and live load are 3 kN/m, 1 kN/m2 and 3 kN/m2

respectively.

Fig. 15.238

Click on the Spans tab. The last defined staircase ap-
pears. Click on the icon to add a new staircase type.
Give this new staircase a reference e.g. Grnd floor, then
click on the icon to define its geometry.

Provide a reference for this staircase geometry (the same
reference may be used). As the slab at which the stair flight
begins has an infill of 47 cm on it, the option Start level
difference must be marked and the value of 47 cm intro-
duced. Activate the Initial steps built on floor box, and
from the emerging window select the second option: Inter-
mediate landing with a turn, unsplit. Indicate there are 2
steps and the rotation is the Same as that of the stairwell
(Left). Click on Accept and select the third option from the
predefined shapes: three straight flights with quarter turn
landings. Introduce 6, 5 and 6 steps for the first, second
and third flights respectively. No steps are to be built on
the intermediate landings. To finish off, indicate that the lan-
dings are to be supported by lateral 20 cm thick masonry
walls.

Fig. 15.239

Accept the dialogue box and click on the to add a new
set of flights to the staircase. Provide a reference (e.g.
Floors) for the stair section, indicate it has 3 equal consecu-
tive flights and click on the icon to define its geometry.

From the predefined shapes, select the third option: three
straight flights with quarter turn landings. Introduce 5 steps
for the first and second flights and 6 steps for the third
flight. Indicate there is a slab length of 30 cm for the fist ho-
rizontal slab. The supports are the same as those on the
Ground floor staircase.

Fig. 15.240
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Having defined the spans of the staircase, introduce it the
same way the stair accessing the basement was introdu-
ced. With the aid of the DXF/DWG template object snaps,
select the initial point of the stair and the second point will
be adjusted by means of its angle.

Fig. 15.241

When the program analyses the job, it will apply the corres-
ponding load at the supports which will be transferred to
the program. However, the staircase can be analysed and
its reinforcement designed without the need of having to
analyse the entire job. To do so, click on the View details
icon from the stairs floating menu, then on the selected
staircase. The program analyses and designs the stair-
case, and concludes by displaying its reinforcement dra-
wings. If the consulted staircase contains more than one
flight, a drop down menu in the top left hand corner of the
drawings window allows the user to select the flight to view.
The stair slab’s forces and displacements, can be seen by
clicking on the corresponding icon in the floating
menu. As with the previous case, if the stair has not yet
been analysed, the program will automatically do so and
display its contour maps.

Fig. 15.242

Fig. 15.243

Having analysed the staircase, the loads it generates can
be seen at the groups where the flights start, end and have
support elements reaching them. Line loads are generated
at these points and surface loads are generated where ini-
tial steps have been built on the floor slab.
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15.3.4.7. Analysis

Having introduced the two stairs in the project, the job can
be analysed. To do so, click on Analyse > Analyse the
job except foundation. Before beginning its calculation,
the program will first analyse the geometry of the structure
and will emit a warning if any incidences are found.

Once the analysis has finished, the program displays any
problems that have been incurred as well as a list of the
elements that are to be checked.

15.3.4.7.1. “Distributed analysis: 2 and 4 processor” mo-
dules

The program has two modules which allow for parallel pro-
cessing using 2 or 4 processors. If the user has acquired
any of these modules, the time taken for the program to
complete the analysis can be reduced significantly as the
processes are shared amongst the two or four processors.
If the module has been acquired, when analysing, the win-
dow displays the number of processors available and how
many are used.

Fig. 15.244

15.3.5. Foundations

The foundations of the job will now be introduced. To do
so, first, place the main view of the screen at Group 0. The
wall strip footings can already be seen (these were defined

when the wall was introduced). The introduction will be com-
pleted by entering the pad footings and strap and tie beams.

15.3.5.1. Pad footings

To enter the pad footings, use the option Foundation >
Foundation elements > New . The New element defi-
nition window will open. Here, select the One column ele-
ments option and click on the first button on the left (rein-
forced concrete footing). Click on the Selection of type but-
ton and choose the eccentric rectangular footing (third op-
tion from the left).

Fig. 15.245

Having accepted the windows, the cursor’s appearance will
change and will adopt the image of a footing. When
brought close to a column, depending on where it is placed
near it, the footing will change to become a corner, edge or
centred footing.

Place the cursor over columns P7, P10, P11, P14 and P15
to introduce the centred footings and to the right of P6 to in-
troduce an edge footing, so not to invade the car lift pit.
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Fig. 15.246

Using the Rotate option , modify the angle of the footing
to adapt it to the edge of the car lift pit. Upon activating this
option, a further three options are available to modify the
angle: Manual introduction, two point introduction or angle
introduction. The two point introduction will be used .
Using the car lift pit outlined on the DXF/DWG template
outline, mark the two points defining the angle (first the bot-
tom point then the top), then click on the footing which is to
have this assigned to it.

Fig. 15.247

Fig. 15.248

15.3.5.2. Strap and tie beams

The strap and tie beams will now be introduced between the
footings. Using the option: Foundation > Strap and tie be-
ams > Beam with automatic balancing at the ends (this
way, the program automatically detects if the footing is an
edge or corner footing and introduces a strap beam, other-
wise a tie beam is defined), introduce the beams.

Fig. 15.249

Click, first of all, on a pad footing and then on the wall strip
footing to introduce the strap beam that will balance the ec-
centricity of the wall footing. Do so with all the pad footings.
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Introduce the beams between the pad footings in such a
way that all the footings remain tied in the two orthogonal di-
rections (required as the job is located in a seismic zone).

Fig. 15.250

The beams defining the perimeter of the lift pit must now be
adjusted: Beams/Walls > Adjust. They are adjusted in the
same way as were the walls in point 13.3.4.1. of this example.

Fig. 15.251

Having introduced the foundation and if the job has been
previously analysed, the foundation elements can be des-
igned. This must be done once the results of the job have
been consulted and modified, as required. If not, problems
can arise. For example if the diameter of the starter bars of
walls and/or columns has been modified, the depth of the
footings may no longer be enough to guarantee the correct
anchorage of the modified reinforcement.

15.3.6. Results

Once the structure has been analysed, any errors that may
have arisen can be verified, and if necessary, the required
modifications can be carried out to amend them.

15.3.6.1. Deformed shape of the structure

It is recommended that before any individual element of the
job is verified, the deformed shape of the structure be
consulted to ensure its displacements are in accordance
with what is to be expected. To do so, click on the Defor-
med Shape tab which will display a wire frame model of
the structure whereby the elements will be drawn in a series
of colours corresponding to displacement values, indica-
ted on the scale at the bottom of the screen.

Fig. 15.252
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Here, the displacement values can also be checked to
comply with the selected code. The program also provides
a report where the distortions of the columns of the job are
indicated. By clicking on the Reports button at the top
of the screen, a list of the available reports is shown. Select
Column distortions and a list will appear indicating the
absolute and relative distortions of each column.

Fig. 15.253

Fig. 15.254

If the distortions are not verified, the structure’s stiffness
must be increased and then re-launch an analysis.

To consult the displacements in a specific floor, the program
contains a Contour maps tab allowing the user to view the
displacements for each loadcase or combination loadcase
by means of contour lines with values or contour maps.

Fig. 15.255

15.3.6.2. Columns

Having checked the deformed shape of the structure, its
columns are next in line to be checked. Any columns not
verifying a check are displayed in red. To consult these er-
rors, click on the Results tab, select Columns > Edit,
then click on a column.

The Column editor window opens listing all the columns on
the left hand side. Columns with design errors have a red
cross displayed next to them.

In this example P2 is displayed in red. Click on it in the Co-
lumn edition section. The Reinforcement edition section
indicates that the ground floor span fails.
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Fig. 15.256

By clicking on the Code checks option at the top of the
Column editon window, the program displays a report de-
tailing all the checks which are carried out and whether the
column in question passes or fails the check. This way, the
reason why the column fails can be consulted. In this case
it is because of the stirrups. Change the column section to
40×40cm at that span, by changing the X dimension value
in the table. Click on Redesign reinforcement, and the
column will then be displayed in green to indicate it no lon-
ger fails.

Now we can group the columns. The dimensions of co-
lumns P3, P4, P5, P8, P9, P13, P15 and P16 match at all
their spans. They all require similar reinforcement except
P3 and P4 which require slightly more. So not to penalise
all the columns, P3 and P4 will be grouped separately.
Click on P9 (which is the column which requires the most
reinforcement) in the Column group section then on
Groups > Copy reinforcement to other groups. Within the
window which opens, click on the columns to which the
reinforcement is to be matched, or alternatively, mark them
on the column on the left.

Fig. 15.257

The selected columns will be highlighted in orange. The re-
maining columns will either be blue, which means the rein-
forcement cannot be copied to those columns, or yellow
implying the reinforcement can be copied although it is not
guaranteed to work (the program would warn of this). Click
on Accept.

The Column edition window now displays the columns as a
group. However, P15 fails with this newly assigned reinfor-
cement.

Fig. 15.258
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Select the Ground floor span in the table within the Reinfor-
cement edition section and then P15 in the summary of
Code checks section. Click on the Code checks option at
the top of the window and a report will appear displaying
the checks carried out on the column. Here, we can see
the column fails due to stirrup spacing. Close the report
and change the 24cm spacing to 15cm spacing. At the
same time change the 24cm spacing of the span above to
15cm; this way all the spans have a 15cm stirrup spacing.
Upon changing the values, the column and column group
no longer fail.

Fig. 15.259

The fire resistance check of the columns has also been
carried out. Go to Group 1: Ground Floor. Click on the fire
resistance icon and from the floating menu that ap-
pears, select the fire check of the current group option

. No columns are displayed in red, implying all of them
pass the fire check. However, the floor slab does appear in
red. If it is approached by the cursor, the information box
that appears indicates the ribs should be at least 16mm
thick to pass the check.

Fig. 15.260

By then selecting it using the left mouse button and clicking
with the right, a window appears with more details of the
fire resistance check.

Fig. 15.261



88 CYPECAD

CYPE

Therefore, the waffle slab must be edited and the job rea-
nalysed. Select the Beam Definition tab and click on
Slabs > Panel manager and from the floating menu se-
lect Define panel. Select Waffle slabs. From the emerging
dialogue box click on the Waf. 30+5 rib 12 spacing 82 slab
defined in the table, followed by a click on the edit icon .
Edit the geometry of the slab so its rib width is 16mm and
its spacing 78cm (so the rib distribution remains the same).

Fig. 15.262

The job must be reanalysed due to the slab changes. Ho-
wever, if these had not been present, as the dimensions of
the columns have changed, it is recommended the job be
re-analysed anyway to take into account the increase in
stiffness of these columns.

As the columns have been grouped and modified, and the
job has to be re-analysed, the user has an option available
so that the column modifications are not lost; the program
allows the reinforcement to be blocked. The option can be
accessed by clicking on Columns > Block reinforcement.
Upon activating this option, a window opens displaying all
the columns of the job. By clicking on the columns or by se-
lecting them using a capture window, the columns whose
reinforcement is to be blocked can be chosen.

Fig 15.263

15.3.6.3. Beams

15.3.6.3.1. Errors

The next step consists in checking the incidents and errors
that arise in the beams during the analysis phase. Using
the option Beams/Walls > Beam errors, in the Results
tab, beams displaying errors can be consulted (these are
displayed in red or yellow after the analysis).

Fig. 15.264
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The errors window displays the errors the consulted beam
contains. A button in the bottom left hand corner displays
the current dimensions of the beam and below it, the pro-
posed dimensions the beam is to have in order to correct
the error. The window contains a help button explai-
ning all the possible errors a beam can have.

The colour in which the beam is displayed is related to the
Error evaluation option located in the beam options sec-
tion in the General Data > By position. Here, all the er-
rors that may arise in a beam are displayed, organised in
tabs and by element, (stirrups, concrete, etc.) with an asso-
ciated colour depending on its importance.

Fig. 15.265

15.3.6.3.2. Reinforcement modification

The program contains an option to consult and modify the
beam reinforcement: Beams/Walls > Edit beams in the Re-
sults tab. Using this option, the reinforcement of the various
beam alignments (continuous beams) that have been ana-
lysed can be edited.

15.3.6.3.2.1. Alignments

The program generates an alignment between two beams
if they contain a common node and if the deviation angle of

one with respect to the other does not exceed the value in-
dicated in the option General data > By position > Be-
am options > Beam angle for alignment.

Fig. 15.266

As well as this automatic option, the program contains op-
tions to divide or join alignments generated by the pro-
gram: Beams/Walls > Beam alignments in the Beam
Definition tab.

15.3.6.3.2.2. Edit beams

When this option is selected, and then a beam is clicked
on, a window appears displaying the alignment. For this
example, select the beam spanning between columns P11
and P15 in group 2.

Click on the Longitudinal reinforcement button at
the top left of the screen so it may be modified. Select the
Join option and click on the 3ø10 (bottom reinforce-
ment) to the left of column and once selected, click on the
3ø10 at the centre of the span. A window asking how many
bars are to be joined appears. Indicate 3. The bars will be
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combined to form three individual bars. Repeat the process
with the reinforcement to the right of column P15. The rein-
forcement has to be resituated within the beam. To do so,
click on the Resituate button , which repositions the
modified bars. If the required steel area is verified, the bars
will be displayed in green, otherwise in red.

Fig. 15.267

Fig. 15.268

Fig. 15.269

Once the reinforcement has been resituated, click on Save
to save the modifications. Using the previous or next

Frame or Group buttons, the user can view all the ali-
gnments (frames) of the job.

15.3.6.4. Floor slabs

15.3.6.4.1. Reinforcement modifications

The program designs the slab reinforcement using the
forces obtained from the analysis. In the case of waffle and
flat slabs, the reinforcement may not be very uniform due to
these forces. To avoid this situation and allow for more ho-
mogenous results, the program has a series of tools availa-
ble allowing for the reinforcement to be edited or modified.
These options are located in Flat/Waffle slabs > Modify
reinforcement in the Results tab.

First, the reinforcement to modify must be selected. In this
case, the reinforcement will be matched in the support area
and in the intermediate zones. To do so, the sum of the
steel areas of the ribs is to be found and then divided by
the number of ribs, resulting in a mean steel area which is
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what is to be left. As an example, the process will be car-
ried out in the area supported by columns P5-P6-P9-P10-
P13-P14 on the Ground floor.

The reinforcement modifications can also be carried out wi-
thin the Contour Maps tab. Here, the forces with which
the reinforcement has been designed can be seen whilst
modifying the steel areas and lengths. This can result to be
very helpful as the force distribution can be used as a
guide as to the layout of the reinforcement.

Click on the Results tab and select Flat/Waffle slabs >
Views and mark the following boxes: Additional reinforce-
ment, Predefined reinforcement, Longitudinal and Bottom.

The required reinforcement for the area between P5 and
P6 is of 2ø10 bars per rib. The next rib up requires 1ø12 +
1ø10, then the next two 1ø16 + 1ø10. The 1ø12 + 1ø10
bars will be matched with the 1ø16 + 1ø10 bars.

Fig. 15.270

Go to option Flat/Waffle slabs > Modify reinforcement
> Modify distribution width and mark the Eliminate
overlapped reinforcement box. Click on the lower 1ø16

+ 1ø10 reinforcement (just above the 1ø12 + 1ø10) and
drag the cursor to the rib above it and click with the mouse.
Click on the same rib again and drag the mouse cursor
downwards to the where the 1ø12 + 1ø10 is, finishing off
with a click.

Fig. 15.271

Fig. 15.272
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Fig. 15.273

The reinforcement has been matched. The total steel area
is now greater than what was originally provided by the pro-
gram, which implies the required area is present. If it were
to be the other way around and less steel area is provided,
if there is an adjacent longitudinal beam, it can be edited
and its bottom reinforcement modified to include the ne-
cessary extra steel area.

The process can be repeated for the reinforcement next to
column P13: change the 1ø12 + 1ø10 to 1ø12 + 1ø12
as in the rib above and the 1ø8 + 1ø8 and 1ø10 + 1ø10
to 1ø10 + 1ø8 at both ribs. If no options have been selected
since the last step, the reinforcement can be modified without
having to click on the option again, as the command is still
active. Click on the reinforcement in the rib next to P13 and
drag the mouse cursor to the next. Click on the 1ø10 + 1ø10
rib and drag the cursor to the rib above it. As this is to be
changed to 1ø10 + 1ø8, right click and from the menu select
Modify group. In the emerging window, change the rein-
forcement of the second layer to ø8 and Accept.

Fig. 15.274

Fig. 15.275
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Fig. 15.276

Carry out the same process in the central area and in the
area to the right so to match the reinforcement.

Fig. 15.277

The remaining reinforcement: longitudinal top reinforcement
and transverse top and bottom reinforcement of the floor
and remaining floors can be modified in the same way.

15.3.6.4.2. Copy reinforcement from another group

If the case arises where the floor geometry and loading is
the same for one or more groups, the modifications only
need to be carried out in one group and then using the op-
tion Flat/Waffle slabs > Copy reinforcement from ano-
ther group from the Results tab, the reinforcement can
be copied. To do so, place the main view of the screen at
the floor to which the reinforcement is to be copied, click on
the option and in the floor group window that opens, select
the floor from which the reinforcement is to be copied.

Fig. 15.278

This option shall not be carried out for this examples as the
two floors with equal geometry and loading have already
been grouped.

15.3.6.4.3. Save reinforcement copy of all groups

If a modification has to be undertaken on the job which im-
plies having to re-launch an analysis, so not to loose any
reinforcement modifications, these may be saved (other-
wise, the program will provide the required reinforcement,
regardless of any previous modifications that were carried
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out). This option can be accessed by clicking on
Flat/Waffle slabs > Save reinforcement copy of all groups
in the Results tab.

15.3.6.5. Foundations

15.3.6.5.1. Soil data

Before designing the foundations, the properties of the soil
and concrete to be used for the foundations must be spe-
cified in Job > General data. Having selected the General
data option, click on the Foundation data button . Here,
the allowable bearing pressure for persistent and acciden-
tal situations can be defined. To the right of the allowable
bearing pressure in persistent situations box, a blue arrow
icon is displayed. Upon clicking on it, a table will appear in-
dicating the most common types of soil and their corres-
ponding bearing pressures. In this case select Gravel.
Mark the Consider wind and earthquake combinations.
As the foundations are connected to one another by strap
and tie beams, the Verify footing sliding box need not be
selected.

Fig. 15.279

15.3.6.5.2. Design

The foundations are designed using the option: Founda-
tion > Design. A window will open in which the elements
to design are to be indicated. In this case, select all the ele-
ments and the Iterative design method.

Fig. 15.280

15.3.6.5.3. Footing edition

Having designed the foundations, the elements must be
edited to match the results obtained by the program.

First of all, the strip footing below the wall at the top is to be
edited. Click on Foundation > Foundation elements >
Edit and click on the strip footing. In the emerging win-
dow, click on Geometry and modify the depth of the foo-
ting to 60 cm and the overhang to 49.0 cm (as the right
overhang is 1.0 cm).
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Fig. 15.281

Click on Design > Redesign, to redesign the reinforce-
ment without changing the geometry of the footing. The
program will emit a message indicating the checks have
been verified.

Fig. 15.282

Repeat the process with all the strip footings, giving them a
depth of 60 cm and a total overhang of 50 cm.

The strip footing in the bottom right hand corner has not
been designed due to it being in an area where forces
concentrate as well as not having any strap beams rea-
ching it to balance out the forces. The walls on either side
of it are probably capable of balancing it, but as they do not
reach it at right angles, the program does not bear them in
mind. To avoid this situation, introduce a strap beam from
the footing below column P7 to the strip footing. Edit the
footing geometry and assign the previous dimensions to it.
Click on Design > Minimum dimensions, this way the
initial proposed geometry is maintained and the dimen-
sions of the footing can only increase. The program pro-
poses a footing with an overhang of 70 cm and a depth of
60 cm. Having designed the footing, the strap beam can be
eliminated, confiding in the adjacent walls to balance out
the moment.

Fig. 15.283
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15.3.7. Edition resources

The program has a series of graphics tools available to
draw lines, circles, arcs and dimensions, add texts and
even insert CYPE construction details or from other CAD
programs. The edition resources can be accessed by
clicking on the button in the top toolbar. A window will
open upon its selection where all the drawing options are
listed. These options can be used together with the object
snap options to snap to elements of the program or en-
tities of the DXF/DWG file that has been imported in the job.

Fig. 15.284

15.3.8. Drawings

Having checked all the results, the drawings of the project
can be obtained. To do so, click on the Job drawings but-
ton in the top toolbar . The Drawing selection window
will open. The drawings to be obtained are added one
by one, selecting the type of drawing from the scroll menu.

The configuration of the drawings can be modified as well
as being able to add construction details to the type of se-
lected drawing by clicking on the Details button.

Fig. 15.285

The peripherals to be used must be defined for each dra-
wing as well as specifying whether or not the edition re-
sources used on the floors of the job are to be drawn.

Fig. 15.286

The option of introducing a title block is also available. The
Title block option is located at the bottom of the Drawing
selection window. Upon clicking on it, a file with the title
block can be imported, a default title block can be selected
or, alternatively, the option None can be selected and so
the program will respect the area marked for the title block
when distributing the layout of the drawings.
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Fig. 15.287

Having concluded the drawing selection and clicking on
Accept, the Drawing composition window appears in which
a previous view of the drawings is displayed. The user can
move the elements, modify their scale, as well as move the
element texts before finally printing out the drawings.

Fig. 15.288

15.3.9. Reports

Finally, the program contains a series of reports to aid in the
completion of the Project report. To obtain a list of the avai-
lable reports click on Reports , located to the left of the
drawings button, seen in the previous section. Upon selec-
ting it, a window appears from which the required docu-
ment can be selected.

Fig. 15.289
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